SCENARIO:
You are responsible for the Internet connection of a company called "Wooden Shoe Corp". Their main site is located in Amsterdam and is currently connected with a single connection to an ISP. Because the Internet connection is critical to the company, you decided to become multi-homed by connecting to another provider. To connect to both providers and be ready for the future you decide to implement BGP.
GOAL:
- All IP addresses have been preconfigured for you.
- Configure BGP on all routers, use the Autonomous System (AS) numbers as specified in the topology picture.
- The ISP routers have the following loopbacks:
ISP1 Loopback0: 2.2.2.2 /24
ISP2 Loopback0: 3.3.3.3 /28 - Advertise these loopbacks in BGP and ensure you have reachability from the Amsterdam router.
- Achieve full connectivity, only use BGP to achieve this.
Basic Interface Configuration
ISP1#conf terminalISP1(config)#interface fastEthernet 0/0
ISP1(config-if)#ip address 192.168.12.2 255.255.255.0
ISP1(config-if)#no shutdown
ISP1(config-if)#interface loopback 1
ISP1(config-if)#ip address 2.2.2.2 255.255.255.0
TBILISI#configure terminal
TBILISI(config)#interface fastEthernet 0/0
TBILISI(config-if)#ip address 192.168.12.1 255.255.255.0
TBILISI(config-if)#no shutdown
TBILISI(config-if)#interface fastEthernet 0/1
TBILISI(config-if)#ip address 192.168.13.1 255.255.255.0
TBILISI(config-if)#no shutdown
TBILISI(config-if)#do ping 192.168.12.2
.!!!!
ISP2(config)#interface fastEthernet 0/0
ISP2(config-if)#ip address 192.168.13.3 255.255.255.0
ISP2(config-if)#no shutdown
ISP2(config-if)#interface loopback 1
ISP2(config-if)#ip address 3.3.3.3 255.255.255.240
ISP2(config-if)#do ping 192.168.13.1
.!!!!
Basic BGP Configuration
ISP1#configure terminalISP1(config)#router bgp 200
ISP1(config-router)#neighbor 192.168.12.1 remote-as 100
ISP1(config-router)#network 2.2.2.0 mask 255.255.255.0
TBILISI#configure terminal
TBILISI(config)#router bgp 100
TBILISI(config-router)#neighbor 192.168.12.2 remote-as 200
TBILISI(config-router)#neighbor 192.168.13.3 remote-as 300
ISP2#configure terminal
ISP2(config-router)#neighbor 192.168.13.1 remote-as 100
ISP2(config-router)#network 3.3.3.0 mask 255.255.255.240
Verify Configuration
ISP2#show ip route bgp
2.0.0.0/24 is subnetted, 1 subnets
B 2.2.2.0 [20/0] via 192.168.13.1, 00:04:09
ISP1#show ip bgp neighbors 192.168.12.1
BGP neighbor is 192.168.12.1, remote AS 100, external link
BGP version 4, remote router ID 192.168.13.1
BGP state = Established, up for 00:10:11
Last read 00:00:11, last write 00:00:11, hold time is 180, keepalive interval is 60 seconds
Neighbor capabilities:
Route refresh: advertised and received(old & new)
Address family IPv4 Unicast: advertised and received
<Lines Omitted>
Connections established 1; dropped 0
Last reset never
Connection state is ESTAB, I/O status: 1, unread input bytes: 0
Connection is ECN Disabled, Mininum incoming TTL 0, Outgoing TTL 1
Local host: 192.168.12.2, Local port: 43043
Foreign host: 192.168.12.1, Foreign port: 179
Connection tableid (VRF): 0
<Lines Omitted>
ISP1#show tcp brief
TCB Local Address Foreign Address (state)
671F6004 192.168.12.2.43043 192.168.12.1.179 ESTAB
TBILISI#show ip bgp
BGP table version is 3, local router ID is 192.168.13.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*> 2.2.2.0/24 192.168.12.2 0 0 200 i
*> 3.3.3.0/28 192.168.13.3 0 0 300 i
TBILISI#show ip bgp summary
BGP router identifier 192.168.13.1, local AS number 100
BGP table version is 3, main routing table version 3
2 network entries using 240 bytes of memory
2 path entries using 104 bytes of memory
3/2 BGP path/bestpath attribute entries using 372 bytes of memory
2 BGP AS-PATH entries using 48 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
Bitfield cache entries: current 1 (at peak 1) using 32 bytes of memory
BGP using 796 total bytes of memory
BGP activity 2/0 prefixes, 2/0 paths, scan interval 60 secs
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
192.168.12.2 4 200 11 12 3 0 0 00:07:07 1
192.168.13.3 4 300 10 11 3 0 0 00:05:23 1
TBILISI#ping 2.2.2.2
!!!!!
Success rate is 100 percent
TBILISI#ping 3.3.3.3
!!!!!
Success rate is 100 percent
##########################################################################################################
BGP table version is 3, local router ID is 192.168.13.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*> 2.2.2.0/24 192.168.12.2 0 0 200 i
*> 3.3.3.0/28 192.168.13.3 0 0 300 i
TBILISI#show ip bgp summary
BGP router identifier 192.168.13.1, local AS number 100
BGP table version is 3, main routing table version 3
2 network entries using 240 bytes of memory
2 path entries using 104 bytes of memory
3/2 BGP path/bestpath attribute entries using 372 bytes of memory
2 BGP AS-PATH entries using 48 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
Bitfield cache entries: current 1 (at peak 1) using 32 bytes of memory
BGP using 796 total bytes of memory
BGP activity 2/0 prefixes, 2/0 paths, scan interval 60 secs
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
192.168.12.2 4 200 11 12 3 0 0 00:07:07 1
192.168.13.3 4 300 10 11 3 0 0 00:05:23 1
TBILISI#ping 2.2.2.2
!!!!!
Success rate is 100 percent
TBILISI#ping 3.3.3.3
!!!!!
Success rate is 100 percent
##########################################################################################################