09 May, 2013

OSPF CCNP LAB Virtual Links, Stubby Area, Redistribution, Authentication and Totally Stubby Area


Objectives:

1) Configure basic OSPF for the network shown. Advertise all networks attached to each router into OSPF using the simplest method avialable.To inject external networks into the OSPF domain, redistribute the static routes on R1.These routers should be marked as type E1.

2) OSPF should never form neighbor relationships on any interface where other OSPF routers do not exist (as shown in the diagram)

3) All routers in Area 0 should use MD5 authentication for OSPF neighbors.Routers in Area 23 should be configured to support clear-text authentication for OSPF neighbors. (All Password : cisco)

4) Routers in Area 45 are limited in the capacity and should not recive routes for network outside the OSPF system.These routers should reach the external network using a default route witch cannot be configured staticlly.

5) Routers in Area 23 must not recive any Type 3,4 and 5 LSAs from the rest of the OSPF network. These routers should reach the external network using a default route with an initial OSPF cost of 100.

6) When this exercise is complere, all routers should be able to reach (ping) every route in the OSPF routing table. 

To See Configuration Click Read More.

Router 1
R1#show run

hostname R1
!
interface FastEthernet0/0
 ip address 10.100.1.1 255.255.255.0
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 cisco
!
router ospf 1
 router-id 1.1.1.1
 redistribute static metric 50 metric-type 1 subnets
 network 10.100.1.1 0.0.0.0 area 0
 network 172.31.0.0 0.0.255.255 area 0
!
ip route 172.31.0.0 255.255.255.0 Null0
ip route 172.31.1.0 255.255.255.0 Null0
ip route 172.31.2.0 255.255.255.0 Null0
ip route 172.31.3.0 255.255.255.0 Null0
!
end

R1#show ip interface brief | in up
FastEthernet0/0            10.100.1.1      YES manual up                    up

R1#show ip route
S       172.31.3.0 is directly connected, Null0
S       172.31.2.0 is directly connected, Null0
S       172.31.1.0 is directly connected, Null0
S       172.31.0.0 is directly connected, Null0
O IA    172.30.2.0 [110/66] via 10.100.1.2, 00:20:27, FastEthernet0/0
O IA    172.30.3.0 [110/66] via 10.100.1.2, 00:20:27, FastEthernet0/0
O IA    172.30.0.0 [110/66] via 10.100.1.2, 00:20:27, FastEthernet0/0
O IA    172.30.1.0 [110/66] via 10.100.1.2, 00:20:33, FastEthernet0/0
O IA    10.23.1.0 [110/65] via 10.100.1.2, 00:33:24, FastEthernet0/0
O IA    10.45.1.0 [110/65] via 10.100.1.4, 00:33:24, FastEthernet0/0
O IA    10.78.1.0 [110/129] via 10.100.1.6, 00:10:07, FastEthernet0/0
O IA    10.67.1.0 [110/65] via 10.100.1.6, 00:33:24, FastEthernet0/0
C       10.100.1.0 is directly connected, FastEthernet0/0

R1#show ip ospf interface fastEthernet 0/0
FastEthernet0/0 is up, line protocol is up
  Internet Address 10.100.1.1/24, Area 0
  Process ID 1, Router ID 1.1.1.1, Network Type BROADCAST, Cost: 1
  Transmit Delay is 1 sec, State DROTHER, Priority 1
  Designated Router (ID) 2.2.2.2, Interface address 10.100.1.2
  Backup Designated router (ID) 6.6.6.6, Interface address 10.100.1.6
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:08
  Supports Link-local Signaling (LLS)
  Cisco NSF helper support enabled
  IETF NSF helper support enabled
  Index 1/1, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 0, maximum is 3
  Last flood scan time is 0 msec, maximum is 4 msec
  Neighbor Count is 3, Adjacent neighbor count is 2
    Adjacent with neighbor 2.2.2.2  (Designated Router)
    Adjacent with neighbor 6.6.6.6  (Backup Designated Router)
  Suppress hello for 0 neighbor(s)
  Message digest authentication enabled
    Youngest key id is 1

R1#show ip ospf neighbor
Neighbor ID     Pri   State           Dead Time   Address         Interface
2.2.2.2           1   FULL/DR         00:00:34    10.100.1.2      FastEthernet0/0
4.4.4.4           1   2WAY/DROTHER    00:00:32    10.100.1.4      FastEthernet0/0
6.6.6.6           1   FULL/BDR        00:00:30    10.100.1.6      FastEthernet0/0

Router 2

R2#show running-config


hostname R2
!
interface FastEthernet0/0
 ip address 10.100.1.2 255.255.255.0
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 cisco
!
interface Serial1/0
 ip address 10.23.1.2 255.255.255.0
 ip ospf authentication
 ip ospf authentication-key cisco
 clock rate 2016000
!
router ospf 1
 router-id 2.2.2.2
 area 23 stub no-summary
 area 23 default-cost 100    (To configure Initial Cost)
 passive-interface default
 no passive-interface FastEthernet0/0
 no passive-interface Serial1/0
 network 10.23.1.2 0.0.0.0 area 23
 network 10.100.1.2 0.0.0.0 area 0
!
end

R2#show ip interface brief | in up
FastEthernet0/0            10.100.1.2      YES manual up                    up
Serial1/0                  10.23.1.2       YES manual up                    up

R2#show ip route
O E1    172.31.3.0 [110/51] via 10.100.1.1, 00:25:45, FastEthernet0/0
O E1    172.31.2.0 [110/51] via 10.100.1.1, 00:25:45, FastEthernet0/0
O E1    172.31.1.0 [110/51] via 10.100.1.1, 00:25:45, FastEthernet0/0
O E1    172.31.0.0 [110/51] via 10.100.1.1, 00:25:45, FastEthernet0/0
O       172.30.2.0 [110/65] via 10.23.1.3, 00:24:52, Serial1/0
O       172.30.3.0 [110/65] via 10.23.1.3, 00:24:52, Serial1/0
O       172.30.0.0 [110/65] via 10.23.1.3, 00:24:57, Serial1/0
O       172.30.1.0 [110/65] via 10.23.1.3, 00:24:57, Serial1/0
C       10.23.1.0 is directly connected, Serial1/0
O IA    10.45.1.0 [110/65] via 10.100.1.4, 00:25:51, FastEthernet0/0
O IA    10.78.1.0 [110/129] via 10.100.1.6, 00:14:44, FastEthernet0/0
O IA    10.67.1.0 [110/65] via 10.100.1.6, 00:25:54, FastEthernet0/0
C       10.100.1.0 is directly connected, FastEthernet0/0

R2#show ip ospf interface
FastEthernet0/0 is up, line protocol is up
  Internet Address 10.100.1.2/24, Area 0
  Process ID 1, Router ID 2.2.2.2, Network Type BROADCAST, Cost: 1
  Transmit Delay is 1 sec, State DR, Priority 1
  Designated Router (ID) 2.2.2.2, Interface address 10.100.1.2
  Backup Designated router (ID) 6.6.6.6, Interface address 10.100.1.6
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:08
  Supports Link-local Signaling (LLS)
  Cisco NSF helper support enabled
  IETF NSF helper support enabled
  Index 1/2, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 1, maximum is 3
  Last flood scan time is 0 msec, maximum is 4 msec
  Neighbor Count is 3, Adjacent neighbor count is 3
    Adjacent with neighbor 1.1.1.1
    Adjacent with neighbor 4.4.4.4
    Adjacent with neighbor 6.6.6.6  (Backup Designated Router)
  Suppress hello for 0 neighbor(s)
  Message digest authentication enabled
    Youngest key id is 1
Serial1/0 is up, line protocol is up
  Internet Address 10.23.1.2/24, Area 23
  Process ID 1, Router ID 2.2.2.2, Network Type POINT_TO_POINT, Cost: 64
  Transmit Delay is 1 sec, State POINT_TO_POINT
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:01
  Supports Link-local Signaling (LLS)
  Cisco NSF helper support enabled
  IETF NSF helper support enabled
  Index 1/1, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 1, maximum is 3
  Last flood scan time is 0 msec, maximum is 4 msec
  Neighbor Count is 1, Adjacent neighbor count is 1
    Adjacent with neighbor 3.3.3.3
  Suppress hello for 0 neighbor(s)
  Simple password authentication enabled

R2#show ip ospf neighbor
Neighbor ID     Pri   State           Dead Time   Address         Interface
1.1.1.1           1   FULL/DROTHER    00:00:34    10.100.1.1      FastEthernet0/0
4.4.4.4           1   FULL/DROTHER    00:00:36    10.100.1.4      FastEthernet0/0
6.6.6.6           1   FULL/BDR        00:00:34    10.100.1.6      FastEthernet0/0
3.3.3.3           0   FULL/  -        00:00:34    10.23.1.3       Serial1/0

Router 3
R3#show run
hostname R3
!
interface Loopback0
 ip address 172.30.0.1 255.255.255.0
 ip ospf network point-to-point
!
interface Loopback1
 ip address 172.30.1.1 255.255.255.0
 ip ospf network point-to-point
!
interface Loopback2
 ip address 172.30.2.1 255.255.255.0
 ip ospf network point-to-point
!
interface Loopback3
 ip address 172.30.3.1 255.255.255.0
 ip ospf network point-to-point
!
interface Serial1/0
 ip address 10.23.1.3 255.255.255.0
 ip ospf authentication
 ip ospf authentication-key cisco
 clock rate 2016000
!
router ospf 1
 router-id 3.3.3.3
 area 23 stub
 passive-interface default
 no passive-interface Serial1/0
 network 10.23.1.3 0.0.0.0 area 23
 network 172.30.0.0 0.0.255.255 area 23
!
end

R3#show ip interface brief | in up
Serial1/0                  10.23.1.3       YES manual up                    up
Loopback0                  172.30.0.1      YES manual up                    up
Loopback1                  172.30.1.1      YES manual up                    up
Loopback2                  172.30.2.1      YES manual up                    up
Loopback3                  172.30.3.1      YES manual up                    up

R3#show ip route
C       172.30.2.0 is directly connected, Loopback2
C       172.30.3.0 is directly connected, Loopback3
C       172.30.0.0 is directly connected, Loopback0
C       172.30.1.0 is directly connected, Loopback1
C       10.23.1.0 is directly connected, Serial1/0
O*IA 0.0.0.0/0 [110/164] via 10.23.1.2, 00:21:58, Serial1/0

R3#show ip ospf interface
Serial1/0 is up, line protocol is up
  Internet Address 10.23.1.3/24, Area 23
  Process ID 1, Router ID 3.3.3.3, Network Type POINT_TO_POINT, Cost: 64
  Transmit Delay is 1 sec, State POINT_TO_POINT
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:02
  Supports Link-local Signaling (LLS)
  Cisco NSF helper support enabled
  IETF NSF helper support enabled
  Index 1/1, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 1, maximum is 1
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 1, Adjacent neighbor count is 1
    Adjacent with neighbor 2.2.2.2
  Suppress hello for 0 neighbor(s)
  Simple password authentication enabled

R3#show ip ospf neighbor
Neighbor ID     Pri   State           Dead Time   Address         Interface
2.2.2.2           0   FULL/  -        00:00:31    10.23.1.2       Serial1/0

Router 4
R4#show running-config
hostname R4
!
interface FastEthernet0/0
 ip address 10.100.1.4 255.255.255.0
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 cisco
!
interface Serial1/0
 ip address 10.45.1.4 255.255.255.0
 clock rate 2016000
!
router ospf 1
 router-id 4.4.4.4
 area 45 stub
 passive-interface default
 no passive-interface FastEthernet0/0
 no passive-interface Serial1/0
 network 10.45.1.4 0.0.0.0 area 45
 network 10.100.1.4 0.0.0.0 area 0
!
end

R4#show ip interface brief | in up
FastEthernet0/0            10.100.1.4      YES manual up                    up
Serial1/0                  10.45.1.4       YES manual up                    up

R4#show ip route
O E1    172.31.3.0 [110/51] via 10.100.1.1, 00:36:01, FastEthernet0/0
O E1    172.31.2.0 [110/51] via 10.100.1.1, 00:36:01, FastEthernet0/0
O E1    172.31.1.0 [110/51] via 10.100.1.1, 00:36:01, FastEthernet0/0
O E1    172.31.0.0 [110/51] via 10.100.1.1, 00:36:01, FastEthernet0/0
O IA    172.30.2.0 [110/66] via 10.100.1.2, 00:30:54, FastEthernet0/0
O IA    172.30.3.0 [110/66] via 10.100.1.2, 00:30:54, FastEthernet0/0
O IA    172.30.0.0 [110/66] via 10.100.1.2, 00:31:00, FastEthernet0/0
O IA    172.30.1.0 [110/66] via 10.100.1.2, 00:31:00, FastEthernet0/0
O IA    10.23.1.0 [110/65] via 10.100.1.2, 00:36:06, FastEthernet0/0
C       10.45.1.0 is directly connected, Serial1/0
O IA    10.78.1.0 [110/129] via 10.100.1.6, 00:20:46, FastEthernet0/0
O IA    10.67.1.0 [110/65] via 10.100.1.6, 00:36:09, FastEthernet0/0
C       10.100.1.0 is directly connected, FastEthernet0/0

R4#show ip ospf interface
FastEthernet0/0 is up, line protocol is up
  Internet Address 10.100.1.4/24, Area 0
  Process ID 1, Router ID 4.4.4.4, Network Type BROADCAST, Cost: 1
  Transmit Delay is 1 sec, State DROTHER, Priority 1
  Designated Router (ID) 2.2.2.2, Interface address 10.100.1.2
  Backup Designated router (ID) 6.6.6.6, Interface address 10.100.1.6
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:03
  Supports Link-local Signaling (LLS)
  Cisco NSF helper support enabled
  IETF NSF helper support enabled
  Index 1/2, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 1, maximum is 1
  Last flood scan time is 0 msec, maximum is 4 msec
  Neighbor Count is 3, Adjacent neighbor count is 2
    Adjacent with neighbor 2.2.2.2  (Designated Router)
    Adjacent with neighbor 6.6.6.6  (Backup Designated Router)
  Suppress hello for 0 neighbor(s)
  Message digest authentication enabled
    Youngest key id is 1
Serial1/0 is up, line protocol is up
  Internet Address 10.45.1.4/24, Area 45
  Process ID 1, Router ID 4.4.4.4, Network Type POINT_TO_POINT, Cost: 64
  Transmit Delay is 1 sec, State POINT_TO_POINT
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:05
  Supports Link-local Signaling (LLS)
  Cisco NSF helper support enabled
  IETF NSF helper support enabled
  Index 1/1, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 4, maximum is 6
  Last flood scan time is 0 msec, maximum is 4 msec
  Neighbor Count is 1, Adjacent neighbor count is 1
    Adjacent with neighbor 5.5.5.5
  Suppress hello for 0 neighbor(s)

R4#show ip ospf neighbor
Neighbor ID     Pri   State           Dead Time   Address         Interface
1.1.1.1           1   2WAY/DROTHER    00:00:33    10.100.1.1      FastEthernet0/0
2.2.2.2           1   FULL/DR         00:00:37    10.100.1.2      FastEthernet0/0
6.6.6.6           1   FULL/BDR        00:00:36    10.100.1.6      FastEthernet0/0
5.5.5.5           0   FULL/  -        00:00:35    10.45.1.5       Serial1/0

Router 5
R5#show run
hostname R5
!
interface Serial1/0
 ip address 10.45.1.5 255.255.255.0
 clock rate 2016000
!
router ospf 1
 router-id 5.5.5.5
 area 45 stub
 passive-interface default
 no passive-interface Serial1/0
 network 10.45.1.5 0.0.0.0 area 45
!
end

R5#show ip interface brief | in up
Serial1/0                  10.45.1.5       YES manual up                    up
R5#show ip route
O IA    172.30.2.0 [110/130] via 10.45.1.4, 00:33:37, Serial1/0
O IA    172.30.3.0 [110/130] via 10.45.1.4, 00:33:37, Serial1/0
O IA    172.30.0.0 [110/130] via 10.45.1.4, 00:33:37, Serial1/0
O IA    172.30.1.0 [110/130] via 10.45.1.4, 00:33:37, Serial1/0
O IA    10.23.1.0 [110/129] via 10.45.1.4, 00:37:41, Serial1/0
C       10.45.1.0 is directly connected, Serial1/0
O IA    10.78.1.0 [110/193] via 10.45.1.4, 00:23:27, Serial1/0
O IA    10.67.1.0 [110/129] via 10.45.1.4, 00:37:46, Serial1/0
O IA    10.100.1.0 [110/65] via 10.45.1.4, 00:37:46, Serial1/0
O*IA 0.0.0.0/0 [110/65] via 10.45.1.4, 00:37:46, Serial1/0

R5#show ip ospf interface
Serial1/0 is up, line protocol is up
  Internet Address 10.45.1.5/24, Area 45
  Process ID 1, Router ID 5.5.5.5, Network Type POINT_TO_POINT, Cost: 64
  Transmit Delay is 1 sec, State POINT_TO_POINT
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:00
  Supports Link-local Signaling (LLS)
  Cisco NSF helper support enabled
  IETF NSF helper support enabled
  Index 1/1, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 1, maximum is 1
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 1, Adjacent neighbor count is 1
    Adjacent with neighbor 4.4.4.4
  Suppress hello for 0 neighbor(s)

R5#show ip ospf neighbor
Neighbor ID     Pri   State           Dead Time   Address         Interface
4.4.4.4           0   FULL/  -        00:00:38    10.45.1.4       Serial1/0

Router 6
R6#show running-config
hostname R6
!
interface FastEthernet0/0
 ip address 10.100.1.6 255.255.255.0
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 cisco
!
interface Serial1/0
 ip address 10.67.1.6 255.255.255.0
 clock rate 2016000
!
router ospf 1
 router-id 6.6.6.6
 area 67 virtual-link 7.7.7.7
 passive-interface default
 no passive-interface FastEthernet0/0
 no passive-interface Serial1/0
 network 10.67.1.6 0.0.0.0 area 67
 network 10.100.1.6 0.0.0.0 area 0
!
end

R6#show ip interface brief | in up
FastEthernet0/0            10.100.1.6      YES manual up                    up
Serial1/0                  10.67.1.6       YES manual up                    up
R6#show ip route
O E1    172.31.3.0 [110/51] via 10.100.1.1, 00:48:37, FastEthernet0/0
O E1    172.31.2.0 [110/51] via 10.100.1.1, 00:48:37, FastEthernet0/0
O E1    172.31.1.0 [110/51] via 10.100.1.1, 00:48:37, FastEthernet0/0
O E1    172.31.0.0 [110/51] via 10.100.1.1, 00:48:37, FastEthernet0/0
O IA    172.30.2.0 [110/66] via 10.100.1.2, 00:35:48, FastEthernet0/0
O IA    172.30.3.0 [110/66] via 10.100.1.2, 00:35:48, FastEthernet0/0
O IA    172.30.0.0 [110/66] via 10.100.1.2, 00:35:54, FastEthernet0/0
O IA    172.30.1.0 [110/66] via 10.100.1.2, 00:35:54, FastEthernet0/0
O IA    10.23.1.0 [110/65] via 10.100.1.2, 00:58:08, FastEthernet0/0
O IA    10.45.1.0 [110/65] via 10.100.1.4, 00:58:08, FastEthernet0/0
O IA    10.78.1.0 [110/128] via 10.67.1.7, 00:25:41, Serial1/0
C       10.67.1.0 is directly connected, Serial1/0
C       10.100.1.0 is directly connected, FastEthernet0/0

R6#show ip ospf interface
OSPF_VL0 is up, line protocol is up
  Internet Address 10.67.1.6/24, Area 0
  Process ID 1, Router ID 6.6.6.6, Network Type VIRTUAL_LINK, Cost: 64
  Configured as demand circuit.
  Run as demand circuit.
  DoNotAge LSA allowed.
  Transmit Delay is 1 sec, State POINT_TO_POINT
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:07
  Supports Link-local Signaling (LLS)
  Cisco NSF helper support enabled
  IETF NSF helper support enabled
  Index 2/3, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 1, maximum is 1
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 1, Adjacent neighbor count is 1
    Adjacent with neighbor 7.7.7.7  (Hello suppressed)
  Suppress hello for 1 neighbor(s)
FastEthernet0/0 is up, line protocol is up
  Internet Address 10.100.1.6/24, Area 0
  Process ID 1, Router ID 6.6.6.6, Network Type BROADCAST, Cost: 1
  Transmit Delay is 1 sec, State BDR, Priority 1
  Designated Router (ID) 2.2.2.2, Interface address 10.100.1.2
  Backup Designated router (ID) 6.6.6.6, Interface address 10.100.1.6
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:02
  Supports Link-local Signaling (LLS)
  Cisco NSF helper support enabled
  IETF NSF helper support enabled
  Index 1/2, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 1, maximum is 2
  Last flood scan time is 4 msec, maximum is 4 msec
  Neighbor Count is 3, Adjacent neighbor count is 3
    Adjacent with neighbor 1.1.1.1
    Adjacent with neighbor 2.2.2.2  (Designated Router)
    Adjacent with neighbor 4.4.4.4
  Suppress hello for 0 neighbor(s)
  Message digest authentication enabled
    Youngest key id is 1
Serial1/0 is up, line protocol is up
  Internet Address 10.67.1.6/24, Area 67
  Process ID 1, Router ID 6.6.6.6, Network Type POINT_TO_POINT, Cost: 64
  Transmit Delay is 1 sec, State POINT_TO_POINT
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:06
  Supports Link-local Signaling (LLS)
  Cisco NSF helper support enabled
  IETF NSF helper support enabled
  Index 1/1, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 4, maximum is 6
  Last flood scan time is 0 msec, maximum is 4 msec
  Neighbor Count is 1, Adjacent neighbor count is 1
    Adjacent with neighbor 7.7.7.7
  Suppress hello for 0 neighbor(s)

R6#show ip ospf virtual-links
Virtual Link OSPF_VL0 to router 7.7.7.7 is up
  Run as demand circuit
  DoNotAge LSA allowed.
  Transit area 67, via interface Serial1/0, Cost of using 64
  Transmit Delay is 1 sec, State POINT_TO_POINT,
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    Hello due in 00:00:01
    Adjacency State FULL (Hello suppressed)
    Index 4/5, retransmission queue length 0, number of retransmission 0
    First 0x0(0)/0x0(0) Next 0x0(0)/0x0(0)
    Last retransmission scan length is 0, maximum is 0
    Last retransmission scan time is 0 msec, maximum is 0 msec

R6#show ip ospf neighbor
Neighbor ID     Pri   State           Dead Time   Address         Interface
7.7.7.7           0   FULL/  -           -        10.67.1.7       OSPF_VL0
1.1.1.1           1   FULL/DROTHER    00:00:32    10.100.1.1      FastEthernet0/0
2.2.2.2           1   FULL/DR         00:00:36    10.100.1.2      FastEthernet0/0
4.4.4.4           1   FULL/DROTHER    00:00:34    10.100.1.4      FastEthernet0/0
7.7.7.7           0   FULL/  -        00:00:29    10.67.1.7       Serial1/0

Router 7
R7#show run
hostname R7
!
interface Serial1/0
 ip address 10.67.1.7 255.255.255.0
 clock rate 2016000
!
interface Serial1/1
 ip address 10.78.1.7 255.255.255.0
 clock rate 2016000
!
router ospf 1
 router-id 7.7.7.7
 area 67 virtual-link 6.6.6.6
 passive-interface default
 no passive-interface Serial1/0
 no passive-interface Serial1/1
 network 10.67.1.7 0.0.0.0 area 67
 network 10.78.1.7 0.0.0.0 area 78
!
end

R7#show ip interface brief | in up
Serial1/0                  10.67.1.7       YES manual up                    up
Serial1/1                  10.78.1.7       YES manual up                    up

R7#show ip route
O E1    172.31.3.0 [110/115] via 10.67.1.6, 00:29:05, Serial1/0
O E1    172.31.2.0 [110/115] via 10.67.1.6, 00:29:05, Serial1/0
O E1    172.31.1.0 [110/115] via 10.67.1.6, 00:29:05, Serial1/0
O E1    172.31.0.0 [110/115] via 10.67.1.6, 00:29:05, Serial1/0
O IA    172.30.2.0 [110/130] via 10.67.1.6, 00:28:12, Serial1/0
O IA    172.30.3.0 [110/130] via 10.67.1.6, 00:28:12, Serial1/0
O IA    172.30.0.0 [110/130] via 10.67.1.6, 00:28:18, Serial1/0
O IA    172.30.1.0 [110/130] via 10.67.1.6, 00:28:18, Serial1/0
O IA    10.23.1.0 [110/129] via 10.67.1.6, 00:28:18, Serial1/0
O IA    10.45.1.0 [110/129] via 10.67.1.6, 00:28:18, Serial1/0
C       10.78.1.0 is directly connected, Serial1/1
C       10.67.1.0 is directly connected, Serial1/0
O       10.100.1.0 [110/65] via 10.67.1.6, 00:28:21, Serial1/0

R7#show ip ospf interface
OSPF_VL0 is up, line protocol is up
  Internet Address 10.67.1.7/24, Area 0
  Process ID 1, Router ID 7.7.7.7, Network Type VIRTUAL_LINK, Cost: 64
  Configured as demand circuit.
  Run as demand circuit.
  DoNotAge LSA allowed.
  Transmit Delay is 1 sec, State POINT_TO_POINT
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:06
  Supports Link-local Signaling (LLS)
  Cisco NSF helper support enabled
  IETF NSF helper support enabled
  Index 1/3, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 1, maximum is 1
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 1, Adjacent neighbor count is 1
    Adjacent with neighbor 6.6.6.6  (Hello suppressed)
  Suppress hello for 1 neighbor(s)
Serial1/0 is up, line protocol is up
  Internet Address 10.67.1.7/24, Area 67
  Process ID 1, Router ID 7.7.7.7, Network Type POINT_TO_POINT, Cost: 64
  Transmit Delay is 1 sec, State POINT_TO_POINT
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:06
  Supports Link-local Signaling (LLS)
  Cisco NSF helper support enabled
  IETF NSF helper support enabled
  Index 1/2, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 1, maximum is 1
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 1, Adjacent neighbor count is 1
    Adjacent with neighbor 6.6.6.6
  Suppress hello for 0 neighbor(s)
Serial1/1 is up, line protocol is up
  Internet Address 10.78.1.7/24, Area 78
  Process ID 1, Router ID 7.7.7.7, Network Type POINT_TO_POINT, Cost: 64
  Transmit Delay is 1 sec, State POINT_TO_POINT
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:06
  Supports Link-local Signaling (LLS)
  Cisco NSF helper support enabled
  IETF NSF helper support enabled
  Index 1/1, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 3, maximum is 3
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 1, Adjacent neighbor count is 1
    Adjacent with neighbor 8.8.8.8
  Suppress hello for 0 neighbor(s)

R7#show ip ospf virtual-links
Virtual Link OSPF_VL0 to router 6.6.6.6 is up
  Run as demand circuit
  DoNotAge LSA allowed.
  Transit area 67, via interface Serial1/0, Cost of using 64
  Transmit Delay is 1 sec, State POINT_TO_POINT,
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    Hello due in 00:00:05
    Adjacency State FULL (Hello suppressed)
    Index 1/2, retransmission queue length 0, number of retransmission 0
    First 0x0(0)/0x0(0) Next 0x0(0)/0x0(0)
    Last retransmission scan length is 0, maximum is 0
    Last retransmission scan time is 0 msec, maximum is 0 msec

R7#show ip ospf neighbor
Neighbor ID     Pri   State           Dead Time   Address         Interface
6.6.6.6           0   FULL/  -           -        10.67.1.6       OSPF_VL0
6.6.6.6           0   FULL/  -        00:00:34    10.67.1.6       Serial1/0
8.8.8.8           0   FULL/  -        00:00:30    10.78.1.8       Serial1/1


Router 8 
R8#show run
hostname R8
!
interface Serial1/1
 ip address 10.78.1.8 255.255.255.0
 clock rate 2016000
!
router ospf 1
 router-id 8.8.8.8
 passive-interface default
 no passive-interface Serial1/1
 network 10.78.1.8 0.0.0.0 area 78
!
end

R8#show ip interface brief | in up
Serial1/1                  10.78.1.8       YES manual up                    up

R8#show ip route
O E1    172.31.3.0 [110/179] via 10.78.1.7, 00:25:30, Serial1/1
O E1    172.31.2.0 [110/179] via 10.78.1.7, 00:25:30, Serial1/1
O E1    172.31.1.0 [110/179] via 10.78.1.7, 00:25:30, Serial1/1
O E1    172.31.0.0 [110/179] via 10.78.1.7, 00:25:30, Serial1/1
O IA    172.30.2.0 [110/194] via 10.78.1.7, 00:25:30, Serial1/1
O IA    172.30.3.0 [110/194] via 10.78.1.7, 00:25:30, Serial1/1
O IA    172.30.0.0 [110/194] via 10.78.1.7, 00:25:36, Serial1/1
O IA    172.30.1.0 [110/194] via 10.78.1.7, 00:25:36, Serial1/1
O IA    10.23.1.0 [110/193] via 10.78.1.7, 00:25:36, Serial1/1
O IA    10.45.1.0 [110/193] via 10.78.1.7, 00:25:36, Serial1/1
C       10.78.1.0 is directly connected, Serial1/1
O IA    10.67.1.0 [110/128] via 10.78.1.7, 00:25:39, Serial1/1
O IA    10.100.1.0 [110/129] via 10.78.1.7, 00:25:39, Serial1/1

R8#show ip ospf interface
Serial1/1 is up, line protocol is up
  Internet Address 10.78.1.8/24, Area 78
  Process ID 1, Router ID 8.8.8.8, Network Type POINT_TO_POINT, Cost: 64
  Transmit Delay is 1 sec, State POINT_TO_POINT
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:02
  Supports Link-local Signaling (LLS)
  Cisco NSF helper support enabled
  IETF NSF helper support enabled
  Index 1/1, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 1, maximum is 1
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 1, Adjacent neighbor count is 1
    Adjacent with neighbor 7.7.7.7
  Suppress hello for 0 neighbor(s)

R8#show ip ospf neighbor
Neighbor ID     Pri   State           Dead Time   Address         Interface
7.7.7.7           0   FULL/  -        00:00:35    10.78.1.7       Serial1/1

R8#traceroute 172.30.1.1
Type escape sequence to abort.
Tracing the route to 172.30.1.1

  1 10.78.1.7 296 msec 252 msec 176 msec
  2 10.67.1.6 264 msec 312 msec 168 msec
  3 10.100.1.2 292 msec 272 msec 228 msec
  4 10.23.1.3 424 msec 432 msec *

R8#ping 172.30.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.30.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 332/572/844 ms