06 July, 2013

BGP DISABLE CONNECTED CHECK




BGP DISABLE CONNECTED CHECK

SCENARIO:

You are a big poker fan and also a master in networking. Your favorite online poker room has been experiencing connection problems and you decided to help them out. They added another link to the service provider for extra redundancy, now the only thing left to do is making sure the BGP configuration is also correct...can you go all-in on this one?

GOAL:

  • All IP addresses have been preconfigured as specified in the topology picture.
  • Create 2 static routes pointing to each others loopback interface:
    For the 10.1.12.X link use an administrative distance of 10.
    For the 10.2.12.X link use an administrative distance of 20.
  • Ensure you can ping every IP address.
  • Configure EBGP and use the correct AS numbers, the updates must be sources from the loopback interfaces.
  • You are not allowed to use EBGP Multihop to solve this problem.

R1#conf terminal
R1(config)#interface fastEthernet 0/0
R1(config-if)#no shutdown
R1(config-if)#ip address 10.2.12.1 255.255.255.252
R1(config-if)#interface fastEthernet 0/1
R1(config-if)#ip address 10.1.12.1 255.255.255.252
R1(config-if)#no shutdown
R1(config-if)#interface lo 0
R1(config-if)#ip address 1.1.1.1 255.255.255.0
R1(config-if)#exit

R1(config)#ip route 2.2.2.2 255.255.255.255 10.1.12.2 10
R1(config)#ip route 2.2.2.2 255.255.255.255 10.2.12.2 20

R1#show ip route static
     2.0.0.0/32 is subnetted, 1 subnets
S       2.2.2.2 [10/0] via 10.1.12.2

R2#configure terminal
R2(config)#interface fastEthernet 0/0
R2(config-if)#ip address 10.2.12.2 255.255.255.252
R2(config-if)#no shutdown
R2(config-if)#interface fastEthernet 0/1
R2(config-if)#ip address 10.1.12.2 255.255.255.252
R2(config-if)#no shutdown
R2(config-if)#interface lo 0
R2(config-if)#ip address 2.2.2.2 255.255.255.0

R2(config-if)#exit


R2(config)#ip route 1.1.1.1 255.255.255.255 10.1.12.1 10
R2(config)#ip route 1.1.1.1 255.255.255.255 10.2.12.1 20

R2#show ip route 1.1.1.1
Routing entry for 1.1.1.1/32
  Known via "static", distance 10, metric 0
  Routing Descriptor Blocks:
  * 10.1.12.1
      Route metric is 0, traffic share count is 1

R2#ping 1.1.1.1 source 2.2.2.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
Packet sent with a source address of 2.2.2.2
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/21/32 ms

Configure BGP
R1#configure terminal
R1(config)#router bgp 1
R1(config-router)#neighbor 2.2.2.2 remote-as 2
R1(config-router)#neighbor 2.2.2.2 update-source loopback 0

R2#configure terminal
R2(config)#router bgp 2
R2(config-router)#neighbor 1.1.1.1 remote-as 1
R2(config-router)#neighbor 1.1.1.1 update-source loopback 0
  • You are not allowed to use EBGP Multihop to solve this problem.
R2(config-router)#neighbor 1.1.1.1 disable-connected-check

R1(config-router)#neighbor 2.2.2.2 disable-connected-check

R1(config-router)#do debug ip bgp
BGP debugging is on for address family: IPv4 Unicast
*Mar  1 00:21:41.323: BGP: 2.2.2.2 open active, local address 1.1.1.1
*Mar  1 00:21:41.379: BGP: 2.2.2.2 went from Active to OpenSent
*Mar  1 00:21:41.379: BGP: 2.2.2.2 sending OPEN, version 4, my as: 1, holdtime 180 seconds
*Mar  1 00:21:41.387: BGP: 2.2.2.2 send message type 1, length (incl. header) 45
*Mar  1 00:21:41.439: BGP: 2.2.2.2 rcv message type 1, length (excl. header) 26
*Mar  1 00:21:41.439: BGP: 2.2.2.2 rcv OPEN, version 4, holdtime 180 seconds
*Mar  1 00:21:41.443: BGP: 2.2.2.2 rcv OPEN w/ OPTION parameter len: 16
*Mar  1 00:21:41.443: BGP: 2.2.2.2 rcvd OPEN w/ optional parameter type 2 (Capability) len 6
*Mar  1 00:21:41.443: BGP: 2.2.2.2 OPEN has CAPABILITY code: 1, length 4
*Mar  1 00:21:41.443: BGP: 2.2.2.2 OPEN has MP_EXT CAP for afi/safi: 1/1
*Mar  1 00:21:41.443: BGP: 2.2.2.2 rcvd OPEN w/ optional parameter type 2 (Capability) len 2
*Mar  1 00:21:41.447: BGP: 2.2.2.2 OPEN has CAPABILITY code: 128, length 0
*Mar  1 00:21:41.447: BGP: 2.2.2.2 OPEN has ROUTE-REFRESH capability(old) for all address-families
*Mar  1 00:21:41.447: BGP: 2.2.2.2 rcvd OPEN w/ optional parameter type 2 (Capability) len 2
*Mar  1 00:21:41.447: BGP: 2.2.2.2 OPEN has CAPABILITY code: 2, length 0
*Mar  1 00:21:41.447: BGP: 2.2.2.2 OPEN has ROUTE-REFRESH capability(new) for all address-families
BGP: 2.2.2.2 rcvd OPEN w/ remote AS 2
*Mar  1 00:21:41.447: BGP: 2.2.2.2 went from OpenSent to OpenConfirm
*Mar  1 00:21:41.447: BGP: 2.2.2.2 went from OpenConfirm to Established
*Mar  1 00:21:41.447: %BGP-5-ADJCHANGE: neighbor 2.2.2.2 Up

R1(config-router)#do show ip bgp summ
BGP router identifier 1.1.1.1, local AS number 1
BGP table version is 1, main routing table version 1
Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
2.2.2.2         4     2       3       3        1    0    0 00:00:40        0

##########################################################################################################