04 July, 2013

BGP ROUTE REFLECTORS



BGP ROUTE REFLECTORS


SCENARIO:

Company Veggie inc. is growing rapidly and the network needs to support the growing company. More routers are added every week and network engineers are complaining it takes too much time to setup BGP. Especially typing in all the neighbor commands is becoming an annoyance for them. Time for you to show up and teach them what a route-reflector is!

GOAL:

  • All IP addresses have been preconfigured as specified in the topology picture.
  • All routers have the following loopback interface:
    Cherry: Loopback0: 1.1.1.1 /24
    Berry: Loopback0: 2.2.2.2 /24
    Dairy: Loopback0: 3.3.3.3 /24
  • Configure OSPF on all routers, ensure you have full reachability.
  • Disable the link between Cherry and Berry.
  • Configure BGP between Cherry and Dairy.
  • Configure BGP between Berry and Dairy.
  • Do not configure BGP between Berry and Cherry.
  • Create a new loopback interface on router Berry:
    Loopback1: 22.22.22.22 /24
  • Advertise this loopback into BGP by using a network command.
  • Ensure you see 22.22.22.0 network in the routing table of router Dairy.
  • Do you see this network in the routing table of router Cherry? Why not?
  • Change the configuration on router Dairy so that router Cherry will have the 22.22.22.0 network in it's routing table (hint: *Route Reflector*).
Configure Basic Configuration and OSPF AS 100 

Cherry#conf terminal
Cherry(config)#interface fastEthernet 0/0
Cherry(config-if)#ip address 192.168.12.1 255.255.255.0
Cherry(config-if)#no shutdown
Cherry(config-if)#interface serial 0/0
Cherry(config-if)#ip address 192.168.13.1 255.255.255.0
Cherry(config-if)#no shutdown
Cherry(config-if)#interface lo 0
Cherry(config-if)#ip address 1.1.1.1 255.255.255.0
Cherry(config-if)#router ospf 100
Cherry(config-router)#network 192.168.12.1 0.0.0.0 area 0
Cherry(config-router)#network 192.168.13.1 0.0.0.0 area 0
Cherry(config-router)#network 1.1.1.1 0.0.0.0 area 0
Cherry(config-router)#end

Berry#conf terminal
Berry(config)#interface fastEthernet 0/0
Berry(config-if)#ip address 192.168.12.2 255.255.255.0
Berry(config-if)#no shutdown
Berry(config-if)#interface serial 0/0
Berry(config-if)#ip address 192.168.23.2 255.255.255.0
Berry(config-if)#no shutdown
Berry(config-if)#interface lo 0
Berry(config-if)#ip address 2.2.2.2 255.255.255.0
Berry(config-if)#router ospf 100
Berry(config-router)#network 192.168.12.2 0.0.0.0 area 0
Berry(config-router)#network 192.168.23.2 0.0.0.0 area 0
Berry(config-router)#network 2.2.2.2 0.0.0.0 area 0
Berry(config-router)#end

Dairy#conf terminal
Dairy(config)#interface serial 0/0
Dairy(config-if)#ip address 192.168.13.3 255.255.255.0
Dairy(config-if)#no shutdown
Dairy(config-if)#interface serial 0/1
Dairy(config-if)#ip address 192.168.23.3 255.255.255.0
Dairy(config-if)#no shutdown
Dairy(config-if)#interface lo 0
Dairy(config-if)#ip address 3.3.3.3 255.255.255.0
Dairy(config-if)#router ospf 100
Dairy(config-router)#network 192.168.13.3 0.0.0.0 area 0
Dairy(config-router)#network 192.168.23.3 0.0.0.0 area 0
Dairy(config-router)#network 3.3.3.3 0.0.0.0 area 0
Dairy(config-router)#end

Dairy#show ip route ospf 100 | include 65
O       1.1.1.1 [110/65] via 192.168.13.1, 00:04:04, Serial0/0
O       2.2.2.2 [110/65] via 192.168.23.2, 00:03:54, Serial0/1
  • Disable the link between Cherry and Berry.
Berry#configure terminal
Berry(config)#interface fastEthernet 0/0
Berry(config-if)#shutdown

Berry#show ip interface brief fastEthernet 0/0
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            192.168.12.2    YES manual administratively down down
  • Configure BGP between Cherry and Dairy.
  • Configure BGP between Berry and Dairy.
Berry#configure terminal
Berry(config)#router bgp 100
Berry(config-router)#neighbor 3.3.3.3 remote-as 100
Berry(config-router)#neighbor 3.3.3.3 update-source loopback 0

Cherry#configure terminal
Cherry(config)#router bgp 100
Cherry(config-router)#neighbor 3.3.3.3 remote-as 100
Cherry(config-router)#neighbor 3.3.3.3 update-source loopback 0

Dairy#configure terminal
Dairy(config)#router bgp 100
Dairy(config-router)#neighbor 1.1.1.1 remote-as 100
Dairy(config-router)#neighbor 1.1.1.1 update-source loopback 0
Dairy(config-router)#neighbor 2.2.2.2 remote-as 100
Dairy(config-router)#neighbor 2.2.2.2 update-source loopback 0

Dairy#show ip bgp summary
BGP router identifier 3.3.3.3, local AS number 100
BGP table version is 1, main routing table version 1

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
1.1.1.1         4   100       6       6        1    0    0 00:02:21        0
2.2.2.2         4   100       6       6        1    0    0 00:03:38        0
  • Create a new loopback interface on router Berry:
    Loopback1: 22.22.22.22 /24
  • Advertise this loopback into BGP by using a network command.
Berry#configure terminal
Berry(config)#interface Loopback 1
Berry(config-if)#ip address 22.22.22.22 255.255.255.0
Berry(config-if)#router bgp 100
Berry(config-router)#network 22.22.22.0 mask 255.255.255.0
  • Ensure you see 22.22.22.0 network in the routing table of router Dairy.
Dairy#show ip route | in 22.22.22.0
B       22.22.22.0 [200/0] via 2.2.2.2, 00:02:47

Dairy#show ip route 22.22.22.0 255.255.255.0
Routing entry for 22.22.22.0/24
  Known via "bgp 100", distance 200, metric 0, type internal
  Last update from 2.2.2.2 00:02:05 ago
  Routing Descriptor Blocks:
  * 2.2.2.2, from 2.2.2.2, 00:02:05 ago
      Route metric is 0, traffic share count is 1
      AS Hops 0

Dairy#show ip bgp
BGP table version is 2, local router ID is 3.3.3.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*>i22.22.22.0/24    2.2.2.2                  0    100      0 i
  • Do you see this network in the routing table of router Cherry? Why not?
Cherry#show ip route | include 22.22.22
Cherry#show ip bgp

To Fix This Problem 

1. configure BGP between Cherry and Barry
2. Configure Router Dairy as ROUTE REFLECTOR 
  • Change the configuration on router Dairy so that router Cherry will have the 22.22.22.0 network in it's routing table (hint: *Route Reflector*).

Dairy#conf terminal
Dairy(config)#router bgp 100
Dairy(config-router)#neighbor 1.1.1.1 route-reflector-client
Dairy(config-router)#neighbor 2.2.2.2 route-reflector-client

Cherry#show ip bgp
BGP table version is 4, local router ID is 1.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*>i22.22.22.0/24    2.2.2.2                  0    100      0 i

Cherry#show ip route bgp
     22.0.0.0/24 is subnetted, 1 subnets
B       22.22.22.0 [200/0] via 2.2.2.2, 00:14:31

Cherry#ping 22.22.22.22

!!!!!
##########################################################################################################