06 July, 2013

CONFIGURE BGP UPDATE-SOURCE

SCENARIO:

As the senior network engineer of a international fruit-selling company you need to configure IBGP within the network. Since your manager wants no SPOF (single point of failure) you decide to add another link between the routers, now the only thing left to do is make sure the logical configuration is also redundant...back to work!

GOAL:

  • All IP addresses have been preconfigured for you.
  • Both routers have a loopback interface:
    Router barcelona: L0: 1.1.1.1 /32
    Router tbilisi: L0: 2.2.2.2 /32
  • Configure EIGRP AS 100 on both routers, advertise all networks.
  • Ensure you have full reachability and can ping both loopbacks.
  • Configure BGP AS 100 on both routers, do not advertise any networks.
  • Make sure that whenever a single link goes down, the BGP neighbor relationship will not reset itself.
  • Try this by first shutting down the FastEthernet link, bring it back up and then try the serial link.

Configure Basic Config And EIGRP

barcelona#configure terminal
barcelona(config)#interface fastEthernet 0/0
barcelona(config-if)#ip address 192.168.112.1 255.255.255.252
barcelona(config-if)#no shutdown
barcelona(config-if)#interface serial 0/0
barcelona(config-if)#ip address 192.168.122.1 255.255.255.252
barcelona(config-if)#no shutdown
barcelona(config-if)#interface lo 0
barcelona(config-if)#ip address 1.1.1.1 255.255.255.255

barcelona(config-if)#router eigrp 100
barcelona(config-router)#no auto-summary
barcelona(config-router)#network 192.168.112.1 0.0.0.0
barcelona(config-router)#network 192.168.122.1 0.0.0.0
barcelona(config-router)#network 1.1.1.1 0.0.0.0
barcelona(config-router)#end

tbilisi#configure terminal
tbilisi(config)#interface fastEthernet 0/0
tbilisi(config-if)#ip address 192.168.112.2 255.255.255.252
tbilisi(config-if)#no shutdown
tbilisi(config-if)#interface serial 0/0
tbilisi(config-if)#ip address 192.168.122.2 255.255.255.252
tbilisi(config-if)#no shutdown
tbilisi(config-if)#interface lo 0
tbilisi(config-if)#ip address 2.2.2.2 255.255.255.255

tbilisi(config-if)#router eigrp 100
tbilisi(config-router)#no auto-summary
tbilisi(config-router)#network 2.2.2.2 0.0.0.0
tbilisi(config-router)#network 192.168.112.2 0.0.0.0
tbilisi(config-router)#network 192.168.112.2 0.0.0.0
tbilisi(config-router)#network 192.168.122.2 0.0.0.0
tbilisi(config-router)#end
tbilisi#ping 1.1.1.1 source lo 0
!!!!!

Configure BGP With Update Source

barcelona#configure terminal
barcelona(config)#router bgp 100
barcelona(config-router)#neighbor 2.2.2.2 remote-as 100
barcelona(config-router)#neighbor 2.2.2.2 update-source lo 0

tbilisi#configure terminal
tbilisi(config)#router bgp 100
tbilisi(config-router)#neighbor 1.1.1.1 remote-as 100
tbilisi(config-router)#neighbor 1.1.1.1 update-source lo 0

Goal:

barcelona#show ip route | inc 2.2.2.2
D       2.2.2.2 [90/409600] via 192.168.112.2, 00:10:29, FastEthernet0/0

If we Shut down FastEthernet0/0 Interface The EIGRP Change it to Serial 0/0

barcelona#debug ip bgp
BGP debugging is on for address family: IPv4 Unicast
barcelona#conf ter
barcelona(config)#int fa0/0
barcelona(config-if)#shutdown

*Mar  1 00:22:20.995: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 192.168.112.2 (FastEthernet0/0) is down: interface down

*Mar  1 00:22:22.959: %LINK-5-CHANGED: Interface FastEthernet0/0, changed state to administratively down

*Mar  1 00:22:23.959: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to down

barcelona(config-if)#do show ip route | include 2.2.2.2
D       2.2.2.2 [90/2297856] via 192.168.122.2, 00:00:24, Serial0/0

We Can Still Reach To The 2.2.2.2 Address Using Interface Serial 0/0

barcelona#show ip bgp neighbors | section 2.2.2.2
BGP neighbor is 2.2.2.2,  remote AS 100, internal link
  BGP version 4, remote router ID 2.2.2.2
  BGP state = Established, up for 00:12:20
  Last read 00:00:19, last write 00:00:19, hold time is 180, keepalive interval is 60 seconds
  Neighbor capabilities:
    Route refresh: advertised and received(old & new)
    Address family IPv4 Unicast: advertised and received
  Message statistics:
    InQ depth is 0
    OutQ depth is 0
                         Sent       Rcvd
    Opens:                  1          1
    Notifications:          0          0
    Updates:                0          0
    Keepalives:            14         14
    Route Refresh:          0          0
    Total:                 15         15
  Default minimum time between advertisement runs is 0 seconds
Foreign host: 2.2.2.2, Foreign port: 179

No BGP debug is appear Here!

BGP Neighborship Never Goes Down If Fails Just One Link !!!

##########################################################################################################