* Check R2 routing table
R2#show ip route 10.1.4.4
Routing entry for 10.1.4.4/32
Known via "ospf 1", distance 110, metric 65, type inter area
Last update from 10.1.245.4 on Serial0/0, 00:01:17 ago
Routing Descriptor Blocks:
* 10.1.245.4, from 10.1.4.4, 00:01:17 ago, via Serial0/0
Route metric is 65, traffic share count is 1
R2#ping 10.1.4.4 repeat 1
Sending 1, 100-byte ICMP Echos to 10.1.4.4, timeout is 2 seconds:
.
Success rate is 0 percent (0/1)
R2#ping 10.1.245.4 repeat 1
Sending 1, 100-byte ICMP Echos to 10.1.245.4, timeout is 2 seconds:
.
Success rate is 0 percent (0/1)
* Check R4 routing table
R4#show ip route 10.1.2.2
Routing entry for 10.1.2.2/32
Known via "ospf 1", distance 110, metric 65, type inter area
Last update from 10.1.245.2 on Serial0/0, 00:01:28 ago
Routing Descriptor Blocks:
* 10.1.245.2, from 10.1.2.2, 00:01:28 ago, via Serial0/0
Route metric is 65, traffic share count is 1
R4#ping 10.1.2.2 repeat 1
Sending 1, 100-byte ICMP Echos to 10.1.2.2, timeout is 2 seconds:
.
Success rate is 0 percent (0/1)
R4#ping 10.1.245.2 repeat 1
Sending 1, 100-byte ICMP Echos to 10.1.245.2, timeout is 2 seconds:
.
Success rate is 0 percent (0/1)
* To Fix this problem we need too add new Frame Relay map on both Routers.
R2#show run in se0/0
!
interface Serial0/0
ip address 10.1.245.2 255.255.255.0
encapsulation frame-relay
ip ospf hello-interval 4
ip ospf priority 0
clock rate 2000000
frame-relay map ip 10.1.245.5 205 broadcast
end
R2#conf terminal
R2(config)#in s0/0
R2(config-if)#frame-relay map ip 10.1.245.4 205 broadcast
R4#show run in ser 0/0
!
interface Serial0/0
ip address 10.1.245.4 255.255.255.0
encapsulation frame-relay
ip ospf hello-interval 4
ip ospf priority 0
clock rate 2000000
frame-relay map ip 10.1.245.5 405 broadcast
end
R4#conf ter
R4(config)#in ser 0/0
R4(config-if)#frame-relay map ip 10.1.245.2 405 broadcast
* Check again the connectivity.
R4#ping 10.1.2.2 repeat 20
Sending 20, 100-byte ICMP Echos to 10.1.2.2, timeout is 2 seconds:
!!!!!!!!!!!!!!!!!!!!
Success rate is 100 percent (20/20), round-trip min/avg/max = 1/10/52 ms
R4#ping 10.1.245.2 repeat 20
Sending 20, 100-byte ICMP Echos to 10.1.245.2, timeout is 2 seconds:
!!!!!!!!!!!!!!!!!!!!
Success rate is 100 percent (20/20), round-trip min/avg/max = 1/8/44 ms