Storm Control
- Monitor: Broadcast / MCast / Unicast
- Set Thresholds: % / PPS / BPS
- Set Actions: Slow It Down / Shutdown
* We have 2 trunk interfaces between SW1 and SW2.
! Configure Ports as Trunk
SW2(config)#vlan 50
SW2(config-vlan)#exit
SW2(config)#default int range fas 0/5-6
SW2(config)#int range fas 0/5-6
SW2(config-if-range)#switchport trunk encapsulation dot1q
SW2(config-if-range)#switchport trunk allowed vlan 50
SW2(config-if-range)#switchport mode trunk
SW2(config-if-range)#exit
SW2(config)#in vlan 50
SW2(config-if)#ip address 10.50.0.2 255.255.255.0
SW2(config-if)#no shutdown
SW2(config-if)#do show ip interface brief vlan 50
Interface IP-Address OK? Method Status Protocol
Vlan50 10.50.0.2 YES manual up up
SW1(config)#vlan 50
SW1(config-vlan)#exit
SW1(config)#default int range fas 0/5-6
SW1(config)#int range fas 0/5-6
SW1(config-if-range)#switchport trunk encapsulation dot1q
SW1(config-if-range)#switchport trunk allowed vlan 50
SW1(config-if-range)#switchport mode trunk
SW1(config-if-range)#exit
SW1(config)#in vlan 50
SW1(config-if)#ip address 10.50.0.1 255.255.255.0
SW1(config-if)#no shutdown
SW1(config-if)#do show ip interface brief vlan 50
Interface IP-Address OK? Method Status Protocol
Vlan50 10.50.0.1 YES manual up up
! Check PPS interval
SW2(config)#do show int fas 0/5 | in packets
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
3 packets input, 64 bytes, 0 no buffer
0 input packets with dribble condition detected
4 packets output, 280 bytes, 0 underruns
! Disable STP
SW2(config)#no spanning-tree vlan 50
SW2(config)#no spanning-tree vlan 50
! Make ping
SW2(config)#do ping 10.50.0.1
!!!!!
! Check PPS interval again
SW2(config)#do show int fas 0/5 | in packets
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
494948 packets input, 213124214 bytes, 0 no buffer
0 input packets with dribble condition detected
494878 packets output, 282131230 bytes, 0 underruns
! Check CPU utilization
SW2(config)#do show process cpu
CPU utilization for five seconds: 60%/30%; one minute: 59%; five minutes: 32%
! Configure Storm Control
SW2(config)#interface range fastEthernet 0/5-6
SW2(config-if-range)#storm-control broadcast level pps 500 100
! Verify
SW2(config-if-range)#do show storm-control broadcast
Interface Filter State Upper Lower Current
--------- ------------- ----------- ----------- ----------
Fa0/5 Forwarding 500 pps 100 pps 6 pps
Fa0/6 Forwarding 500 pps 100 pps 1 pps
! Verify when storm is in action
SW2(config-if-range)#do show storm-control broadcast
Interface Filter State Upper Lower Current
--------- ------------- ----------- ----------- ----------
Fa0/5 Blocking 500 pps 100 pps 5.5k pps
Fa0/6 Blocking 500 pps 100 pps 5.3k pps
* Note: Now the Broadcast not consuming all bandwidth.
! Change action mode to Shutdown
SW2(config-if-range)#storm-control action shutdown
* Note: If storm occur ports will be set as err-disable state.