GRE Configuration
R1#conf terminal
R1(config)#in lo 0
R1(config-if)#ip address 10.1.1.1 255.255.255.0
R1(config-if)#in fas 0/0
R1(config-if)#ip address 51.10.1.1 255.255.255.252
R1(config-if)#no shutdown
R2#conf terminal
R2(config)#in lo 0
R2(config-if)#ip address 10.1.2.1 255.255.255.0
R2(config-if)#in fas 0/0
R2(config-if)#ip address 51.10.1.2 255.255.255.252
R2(config-if)#no shutdown
R2(config-if)#do ping 51.10.1.1 re 1
!
! Create GRE Tunnel
R1(config)#do show ip inter bri | exc unas
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 51.10.1.1 YES manual up up
Loopback0 10.1.1.1 YES manual up up
R1(config)#interface tunnel 12
R1(config-if)#tunnel source 51.10.1.1
R1(config-if)#tunnel destination 51.10.1.2
R1(config-if)#ip address 192.168.0.1 255.255.255.0
R2(config)#interface tunnel 12
R2(config-if)#tunnel source 51.10.1.2
R2(config-if)#tunnel destination 51.10.1.1
R2(config-if)#ip address 192.168.0.2 255.255.255.0
R2(config-if)#do show ip inter bri | exc unas
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 51.10.1.2 YES manual up up
Loopback0 10.1.2.1 YES manual up up
Tunnel12 192.168.0.2 YES manual up up
! Configure RIP
R1(config)#router rip
R1(config-router)#version 2
R1(config-router)#no auto-summary
R1(config-router)#network 192.168.0.0
R1(config-router)#network 10.0.0.0
R1(config-router)#exit
R2(config)#router rip
R2(config-router)#version 2
R2(config-router)#no auto-summary
R2(config-router)#network 192.168.0.0
R2(config-router)#network 10.0.0.0
R2(config-router)#end
R2#show ip route
R 10.1.1.0/24 [120/1] via 192.168.0.1, 00:00:01, Tunnel12
C 10.1.2.0/24 is directly connected, Loopback0
51.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 51.10.1.0/30 is directly connected, FastEthernet0/0
192.168.0.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.0.0/24 is directly connected, Tunnel12
Ping Capture file here