30 April, 2013

OSPF Routing - Implementing Basic OSPF


Objectives:

1. Configure OSPF for the above network diagram. R1 will act as an ASBR by redistributing a series of static routes into the OSPF network. These routers should NOT increment their metric as they pass through the network and should have an initial OSPF cost of 200. All routers should have a router-id reflecting their hostname; you should be able to ping this router-id throughout the entire OSPF network.

2. After completing the initial step of the lab, one of the routers in Area 0 will become the DR and one will become BDR for the Ethernet segment. Which router will become the DR and BDR ? Write DR and BDR next to the respective router below.
  • R1
  • R2 BDR
  • R3 DR
3. Ensure R1 Become the DR on the Ethernet segment in Area 0. R2 and R3 should NOT become a DR and BDR for the Ethernet segment in Area 0. After this change is made, what type of neighbor relationship should exist between R1 and R2 ? What about R2 and R3?

R1 to R2 (Full State)
R1 to R3 (Full State)
R2 to R3 (2-Way State)

4. Implement summarization at the ABRs in the network to make routing table throughout the network as efficient as possible.

5. Implement summarization at the ASBR. The summary route should have the same attributes as the original, individual routes redistributed into the network.

6. The organization plans to upgrade to Gigabit Ethernet in the coming months. OSPF should accurately calculate its metric assuming Gigabit Ethernet will be the fastest link in the network.

To See Configuration Click Read More.



R1#show running-config (Lines Omitted)
hostname R1
!
interface FastEthernet0/0
 ip address 172.30.0.1 255.255.255.0
 ip ospf priority 200
 duplex auto
 speed auto
!
router ospf 1
 router-id 1.1.1.1
 auto-cost reference-bandwidth 1000
 summary-address 172.16.0.0 255.255.252.0
 redistribute static metric 200 subnets
 network 172.30.0.1 0.0.0.0 area 0
!
ip route 172.16.0.0 255.255.255.0 Null0
ip route 172.16.1.0 255.255.255.0 Null0
ip route 172.16.2.0 255.255.255.0 Null0
ip route 172.16.3.0 255.255.255.0 Null0
!
end

R1#show ip interface brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            172.30.0.1      YES manual up                    up
R1#show ip ospf neighbor
Neighbor ID     Pri   State           Dead Time   Address         Interface
2.2.2.2           0   FULL/DROTHER    00:00:33    172.30.0.2      FastEthernet0/0
3.3.3.3           0   FULL/DROTHER    00:00:30    172.30.0.3      FastEthernet0/0
R1#show ip route
     172.16.0.0/16 is variably subnetted, 5 subnets, 2 masks
S       172.16.0.0/24 is directly connected, Null0
O       172.16.0.0/22 is a summary, 01:11:55, Null0
S       172.16.1.0/24 is directly connected, Null0
S       172.16.2.0/24 is directly connected, Null0
S       172.16.3.0/24 is directly connected, Null0
     172.30.0.0/24 is subnetted, 3 subnets
O IA    172.30.20.0 [110/2010] via 172.30.0.3, 01:02:10, FastEthernet0/0
C       172.30.0.0 is directly connected, FastEthernet0/0
O IA    172.30.10.0 [110/2010] via 172.30.0.2, 01:02:23, FastEthernet0/0
     10.0.0.0/22 is subnetted, 2 subnets
O IA    10.10.0.0 [110/2011] via 172.30.0.2, 01:02:24, FastEthernet0/0
O IA    10.20.0.0 [110/2011] via 172.30.0.3, 01:02:13, FastEthernet0/0

R2#show running-config (Lines Omitted)
hostname R2
!
interface FastEthernet0/0
 ip address 172.30.0.2 255.255.255.0
 ip ospf priority 0
 duplex auto
 speed auto
!
interface Serial1/0
 bandwidth 500
 ip address 172.30.10.2 255.255.255.0
 clock rate 504000
!
router ospf 1
 router-id 2.2.2.2
 auto-cost reference-bandwidth 1000
 area 10 range 10.10.0.0 255.255.252.0
 network 172.30.0.2 0.0.0.0 area 0
 network 172.30.10.2 0.0.0.0 area 10
!
end
R2#show ip interface brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            172.30.0.2      YES manual up                    up
Serial1/0                  172.30.10.2     YES manual up                    up
R2#show ip ospf neighbor
Neighbor ID     Pri   State           Dead Time   Address         Interface
1.1.1.1         200   FULL/DR         00:00:35    172.30.0.1      FastEthernet0/0
3.3.3.3           0   2WAY/DROTHER    00:00:31    172.30.0.3      FastEthernet0/0
5.5.5.5           0   FULL/  -        00:00:30    172.30.10.5     Serial1/0
R2#show ip route
     172.16.0.0/22 is subnetted, 1 subnets
O E2    172.16.0.0 [110/200] via 172.30.0.1, 01:17:27, FastEthernet0/0
     172.30.0.0/24 is subnetted, 3 subnets
O IA    172.30.20.0 [110/2010] via 172.30.0.3, 01:07:41, FastEthernet0/0
C       172.30.0.0 is directly connected, FastEthernet0/0
C       172.30.10.0 is directly connected, Serial1/0
     10.0.0.0/8 is variably subnetted, 6 subnets, 2 masks
O       10.10.0.0/24 [110/2001] via 172.30.10.5, 01:07:53, Serial1/0
O       10.10.0.0/22 is a summary, 01:07:57, Null0
O       10.10.1.0/24 [110/2001] via 172.30.10.5, 01:07:57, Serial1/0
O       10.10.2.0/24 [110/2001] via 172.30.10.5, 01:07:57, Serial1/0
O       10.10.3.0/24 [110/2001] via 172.30.10.5, 01:07:57, Serial1/0
O IA    10.20.0.0/22 [110/2011] via 172.30.0.3, 01:07:45, FastEthernet0/0

R3#show running-config  (Lines Omitted)
hostname R3
!
interface FastEthernet0/0
 ip address 172.30.0.3 255.255.255.0
 ip ospf priority 0
 duplex auto
 speed auto
!
interface Serial1/0
 bandwidth 500
 ip address 172.30.20.3 255.255.255.0
 clock rate 504000
!
router ospf 1
 router-id 3.3.3.3
 auto-cost reference-bandwidth 1000
 area 20 range 10.20.0.0 255.255.252.0
 network 172.30.0.3 0.0.0.0 area 0
 network 172.30.20.3 0.0.0.0 area 20
!
end
R3#show ip interface brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            172.30.0.3      YES manual up                    up
Serial1/0                  172.30.20.3     YES manual up                    up
R3#show ip ospf neighbor
Neighbor ID     Pri   State           Dead Time   Address         Interface
1.1.1.1         200   FULL/DR         00:00:30    172.30.0.1      FastEthernet0/0
2.2.2.2           0   2WAY/DROTHER    00:00:37    172.30.0.2      FastEthernet0/0
4.4.4.4           0   FULL/  -        00:00:36    172.30.20.4     Serial1/0
R3#show ip route
     172.16.0.0/22 is subnetted, 1 subnets
O E2    172.16.0.0 [110/200] via 172.30.0.1, 01:21:13, FastEthernet0/0
     172.30.0.0/24 is subnetted, 3 subnets
C       172.30.20.0 is directly connected, Serial1/0
C       172.30.0.0 is directly connected, FastEthernet0/0
O IA    172.30.10.0 [110/2010] via 172.30.0.2, 01:11:28, FastEthernet0/0
     10.0.0.0/8 is variably subnetted, 6 subnets, 2 masks
O IA    10.10.0.0/22 [110/2011] via 172.30.0.2, 01:11:28, FastEthernet0/0
O       10.20.2.0/24 [110/2001] via 172.30.20.4, 01:11:31, Serial1/0
O       10.20.3.0/24 [110/2001] via 172.30.20.4, 01:11:31, Serial1/0
O       10.20.0.0/24 [110/2001] via 172.30.20.4, 01:11:31, Serial1/0
O       10.20.0.0/22 is a summary, 01:11:31, Null0
O       10.20.1.0/24 [110/2001] via 172.30.20.4, 01:11:31, Serial1/0

R4#show running-config (Lines Omitted)
hostname R4
!
interface Loopback1
 ip address 10.20.0.1 255.255.255.0
 ip ospf network point-to-point
!
interface Loopback2
 ip address 10.20.1.1 255.255.255.0
 ip ospf network point-to-point
!
interface Loopback3
 ip address 10.20.2.1 255.255.255.0
 ip ospf network point-to-point
!
interface Loopback4
 ip address 10.20.3.1 255.255.255.0
 ip ospf network point-to-point
!
interface Serial1/0
 bandwidth 500
 ip address 172.30.20.4 255.255.255.0
!
router ospf 1
 router-id 4.4.4.4
 auto-cost reference-bandwidth 1000
 network 10.20.0.0 0.0.255.255 area 20
 network 172.30.20.4 0.0.0.0 area 20
!
end
R4#show ip interface brief
Interface                  IP-Address      OK? Method Status                Protocol
Serial1/0                  172.30.20.4     YES manual up                    up
Loopback1                  10.20.0.1       YES manual up                    up
Loopback2                  10.20.1.1       YES manual up                    up
Loopback3                  10.20.2.1       YES manual up                    up
Loopback4                  10.20.3.1       YES manual up                    up
R4#show ip ospf neighbor
Neighbor ID     Pri   State           Dead Time   Address         Interface
3.3.3.3           0   FULL/  -        00:00:37    172.30.20.3     Serial1/0
R4#show ip route
     172.16.0.0/22 is subnetted, 1 subnets
O E2    172.16.0.0 [110/200] via 172.30.20.3, 01:24:10, Serial1/0
     172.30.0.0/24 is subnetted, 3 subnets
C       172.30.20.0 is directly connected, Serial1/0
O IA    172.30.0.0 [110/2010] via 172.30.20.3, 01:14:08, Serial1/0
O IA    172.30.10.0 [110/4010] via 172.30.20.3, 01:14:08, Serial1/0
     10.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
O IA    10.10.0.0/22 [110/4011] via 172.30.20.3, 01:14:08, Serial1/0
C       10.20.2.0/24 is directly connected, Loopback3
C       10.20.3.0/24 is directly connected, Loopback4
C       10.20.0.0/24 is directly connected, Loopback1
C       10.20.1.0/24 is directly connected, Loopback2

R5#show running-config (Lines Omitted)
hostname R5
!
interface Loopback1
 ip address 10.10.0.1 255.255.255.0
 ip ospf network point-to-point
!
interface Loopback2
 ip address 10.10.1.1 255.255.255.0
 ip ospf network point-to-point
!
interface Loopback3
 ip address 10.10.2.1 255.255.255.0
 ip ospf network point-to-point
!
interface Loopback4
 ip address 10.10.3.1 255.255.255.0
 ip ospf network point-to-point
!
interface Serial1/0
 bandwidth 500
 ip address 172.30.10.5 255.255.255.0
 clock rate 504000
!
router ospf 1
 router-id 5.5.5.5
 auto-cost reference-bandwidth 1000
 network 10.10.0.0 0.0.255.255 area 10
 network 172.30.10.5 0.0.0.0 area 10
!
end
R5#show ip interface brief
Interface                  IP-Address      OK? Method Status                Protocol
Serial1/0                  172.30.10.5     YES manual up                    up
Loopback1                  10.10.0.1       YES manual up                    up
Loopback2                  10.10.1.1       YES manual up                    up
Loopback3                  10.10.2.1       YES manual up                    up
Loopback4                  10.10.3.1       YES manual up                    up
R5#show ip ospf neighbor
Neighbor ID     Pri   State           Dead Time   Address         Interface
2.2.2.2           0   FULL/  -        00:00:31    172.30.10.2     Serial1/0
R5#show ip route
     172.16.0.0/22 is subnetted, 1 subnets
O E2    172.16.0.0 [110/200] via 172.30.10.2, 01:27:17, Serial1/0
     172.30.0.0/24 is subnetted, 3 subnets
O IA    172.30.20.0 [110/4010] via 172.30.10.2, 01:17:18, Serial1/0
O IA    172.30.0.0 [110/2010] via 172.30.10.2, 01:17:18, Serial1/0
C       172.30.10.0 is directly connected, Serial1/0
     10.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
C       10.10.0.0/24 is directly connected, Loopback1
C       10.10.1.0/24 is directly connected, Loopback2
C       10.10.2.0/24 is directly connected, Loopback3
C       10.10.3.0/24 is directly connected, Loopback4
O IA    10.20.0.0/22 [110/4011] via 172.30.10.2, 01:17:21, Serial1/0