23 May, 2013

CCNP Advanced Redistribution

IPv4 Redistribution - Implementing Advanced Redistribution OSPF And EIGRP



1. Configure EIGRP and OSPF for the network shown (use OSPF Area 0). Advertise all networks on all routers. Do not implement any summarization features for EIGRP or OSPF. Routes should never be advertised both OSPF and EIGRP routing domains.

2. Enable full, mutual redistribution on R2 and R3 between OSPF and EIGRP. The 10.4.0.0/24 and 10.4.1.0/24 subnets should have a seed metric of 100 and an OSPF tag of 10 while the 10.4.2.0/24 and 10.4.3.0/24 subnets should have a seed metric of 200 and an OSPF tag of 20. All other subnets redistributed into OSPF should have a seed metric 300 and OSPF tag of 30. OSPF routes redistributed into EIGRP should have a seed metric of BW: 400 DLY: 20 REL: 255 LD: 1 MTU: 1500 and a tag of 40. Finally, external OSPF routes should not increment their metric as they pass through the OSPF domain.

3. Ensure the 10.4.4.0/24 network does not reach the OSPF routing domain.

4. Enable filtering using the assigned route tags to ensure redistributed routes do not cause any looping issues.

5. R3 has the prefered route to reach the 10.1.0.0/24 network. Ensure routers prefer this path over the path from R2.

To See Configuration Click Read More.


Router 1
R1#show running-config

hostname R1
!
interface Loopback0
 ip address 10.1.0.1 255.255.255.0
 ip ospf network point-to-point
!
interface Serial0/0
 ip address 10.1.13.1 255.255.255.0
 clock rate 2000000
!
interface Serial0/1
 ip address 10.1.12.1 255.255.255.0
 clock rate 2000000
!
router ospf 1
 router-id 1.1.1.1
 log-adjacency-changes
 network 10.1.0.1 0.0.0.0 area 0
 network 10.1.12.1 0.0.0.0 area 0
 network 10.1.13.1 0.0.0.0 area 0
!
end

R1#show ip interface brief | include up
Serial0/0                  10.1.13.1       YES manual up                    up
Serial0/1                  10.1.12.1       YES manual up                    up
Loopback0                  10.1.0.1        YES manual up                    up

R1#show ip route
     10.0.0.0/24 is subnetted, 9 subnets
C       10.1.13.0 is directly connected, Serial0/0
C       10.1.12.0 is directly connected, Serial0/1
C       10.1.0.0 is directly connected, Loopback0
O E2    10.4.2.0 [110/200] via 10.1.13.3, 00:01:41, Serial0/0
                 [110/200] via 10.1.12.2, 00:01:41, Serial0/1
O E2    10.4.3.0 [110/200] via 10.1.13.3, 00:01:41, Serial0/0
                 [110/200] via 10.1.12.2, 00:01:41, Serial0/1
O E2    10.4.0.0 [110/100] via 10.1.13.3, 00:01:41, Serial0/0
                 [110/100] via 10.1.12.2, 00:01:33, Serial0/1
O E2    10.4.1.0 [110/100] via 10.1.13.3, 00:01:43, Serial0/0
                 [110/100] via 10.1.12.2, 00:01:43, Serial0/1
O E2    10.1.24.0 [110/300] via 10.1.13.3, 00:01:43, Serial0/0
                  [110/300] via 10.1.12.2, 00:14:02, Serial0/1
O E2    10.1.23.0 [110/300] via 10.1.13.3, 00:13:05, Serial0/0
                  [110/300] via 10.1.12.2, 00:14:03, Serial0/1

R1#show ip route 10.4.2.0
Routing entry for 10.4.2.0/24
  Known via "ospf 1", distance 110, metric 200
  Tag 20, type extern 2, forward metric 64
  Last update from 10.1.13.3 on Serial0/0, 00:34:41 ago
  Routing Descriptor Blocks:
    10.1.13.3, from 3.3.3.3, 00:34:41 ago, via Serial0/0
      Route metric is 200, traffic share count is 1
      Route tag 20
  * 10.1.12.2, from 2.2.2.2, 00:34:41 ago, via Serial0/1
      Route metric is 200, traffic share count is 1
      Route tag 20

R1#show ip route 10.4.0.0
Routing entry for 10.4.0.0/24
  Known via "ospf 1", distance 110, metric 100
  Tag 10, type extern 2, forward metric 64
  Last update from 10.1.12.2 on Serial0/1, 00:34:44 ago
  Routing Descriptor Blocks:
  * 10.1.13.3, from 3.3.3.3, 00:34:54 ago, via Serial0/0
      Route metric is 100, traffic share count is 1
      Route tag 10
    10.1.12.2, from 2.2.2.2, 00:34:44 ago, via Serial0/1
      Route metric is 100, traffic share count is 1
      Route tag 10

R1#show ip route 10.1.24.0
Routing entry for 10.1.24.0/24
  Known via "ospf 1", distance 110, metric 300
  Tag 30, type extern 2, forward metric 64
  Last update from 10.1.13.3 on Serial0/0, 00:35:03 ago
  Routing Descriptor Blocks:
    10.1.13.3, from 3.3.3.3, 00:35:03 ago, via Serial0/0
      Route metric is 300, traffic share count is 1
      Route tag 30
  * 10.1.12.2, from 2.2.2.2, 00:47:21 ago, via Serial0/1
      Route metric is 300, traffic share count is 1
      Route tag 30

R1#show ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
3.3.3.3           0   FULL/  -        00:00:39    10.1.13.3       Serial0/0
2.2.2.2           0   FULL/  -        00:00:36    10.1.12.2       Serial0/1

Router 2
R2#show running-config

hostname R2
!
interface Serial0/0
 ip address 10.1.24.2 255.255.255.0
 clock rate 2000000
!
interface Serial0/1
 ip address 10.1.23.2 255.255.255.0
 clock rate 2000000
!
interface Serial0/2
 ip address 10.1.12.2 255.255.255.0
 clock rate 2000000
!
router eigrp 100
 redistribute ospf 1 route-map OSPF-TO-EIGRP
 network 10.1.23.0 0.0.0.255
 network 10.1.24.0 0.0.0.255
 distance eigrp 90 105 (External AD)
 no auto-summary
!
router ospf 1
 router-id 2.2.2.2
 redistribute eigrp 100 subnets route-map EIGRP-TO-OSPF
 network 10.1.12.2 0.0.0.0 area 0
!
access-list 1 permit 10.4.0.0 0.0.0.255
access-list 1 permit 10.4.1.0 0.0.0.255
access-list 2 permit 10.4.2.0 0.0.0.255
access-list 2 permit 10.4.3.0 0.0.0.255
access-list 3 permit 10.4.4.0 0.0.0.255
!
route-map EIGRP-TO-OSPF deny 5    (Deny Trafic With Tag)
 match tag 40
!
route-map EIGRP-TO-OSPF permit 10
 match ip address 1
 set metric 100
 set tag 10
!
route-map EIGRP-TO-OSPF permit 20
 match ip address 2
 set metric 200
 set tag 20
!
route-map EIGRP-TO-OSPF deny 30
 match ip address 3
!
route-map EIGRP-TO-OSPF permit 40  (Permit Any)
 set metric 300
 set tag 30
!
route-map OSPF-TO-EIGRP deny 5     (Deny Trafic With Tag)
 match tag 10 20 30
!
route-map OSPF-TO-EIGRP permit 10
 set metric 400 20 255 1 1500
 set tag 40
!
end

R2#show ip interface brief | include up
Serial0/0                  10.1.24.2       YES manual up                    up
Serial0/1                  10.1.23.2       YES manual up                    up
Serial0/2                  10.1.12.2       YES manual up                    up

R2#show ip route
     10.0.0.0/24 is subnetted, 10 subnets
D EX    10.1.13.0 [105/6917120] via 10.1.23.3, 00:04:19, Serial0/1
C       10.1.12.0 is directly connected, Serial0/2
D       10.4.4.0 [90/2297856] via 10.1.24.4, 00:04:19, Serial0/0
D EX    10.1.0.0 [105/6917120] via 10.1.23.3, 00:04:19, Serial0/1
D       10.4.2.0 [90/2297856] via 10.1.24.4, 00:04:19, Serial0/0
D       10.4.3.0 [90/2297856] via 10.1.24.4, 00:04:19, Serial0/0
D       10.4.0.0 [90/2297856] via 10.1.24.4, 00:04:19, Serial0/0
D       10.4.1.0 [90/2297856] via 10.1.24.4, 00:04:21, Serial0/0
C       10.1.24.0 is directly connected, Serial0/0
C       10.1.23.0 is directly connected, Serial0/1

R2#show ip ospf neighbor
Neighbor ID     Pri   State           Dead Time   Address         Interface
1.1.1.1           0   FULL/  -        00:00:33    10.1.12.1       Serial0/2


R2#show ip eigrp neighbors
IP-EIGRP neighbors for process 100
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
1   10.1.24.4               Se0/0             13 00:05:05  228  1368  0  10
0   10.1.23.3               Se0/1             14 00:05:06  320  1920  0  17

R2#show access-lists
Standard IP access list 1
    10 permit 10.4.0.0, wildcard bits 0.0.0.255 (4 matches)
    20 permit 10.4.1.0, wildcard bits 0.0.0.255 (4 matches)
Standard IP access list 2
    10 permit 10.4.2.0, wildcard bits 0.0.0.255 (4 matches)
    20 permit 10.4.3.0, wildcard bits 0.0.0.255 (4 matches)
Standard IP access list 3
    10 permit 10.4.4.0, wildcard bits 0.0.0.255 (4 matches)

R2#show route-map
route-map EIGRP-TO-OSPF, deny, sequence 5
  Match clauses:
    tag 40
  Set clauses:
  Policy routing matches: 0 packets, 0 bytes
route-map EIGRP-TO-OSPF, permit, sequence 10
  Match clauses:
    ip address (access-lists): 1
  Set clauses:
    metric 100
    tag 10
  Policy routing matches: 0 packets, 0 bytes
route-map EIGRP-TO-OSPF, permit, sequence 20
  Match clauses:
    ip address (access-lists): 2
  Set clauses:
    metric 200
    tag 20
  Policy routing matches: 0 packets, 0 bytes
route-map EIGRP-TO-OSPF, deny, sequence 30
  Match clauses:
    ip address (access-lists): 3
  Set clauses:
  Policy routing matches: 0 packets, 0 bytes
route-map EIGRP-TO-OSPF, permit, sequence 40
  Match clauses:
  Set clauses:
    metric 300
    tag 30
  Policy routing matches: 0 packets, 0 bytes
route-map OSPF-TO-EIGRP, deny, sequence 5
  Match clauses:
    tag 10 20 30
  Set clauses:
  Policy routing matches: 0 packets, 0 bytes
route-map OSPF-TO-EIGRP, permit, sequence 10
  Match clauses:
  Set clauses:
    metric 400 20 255 1 1500
    tag 40
  Policy routing matches: 0 packets, 0 bytes

R2#show ip route 10.1.0.0
Routing entry for 10.1.0.0/24
  Known via "eigrp 100", distance 105, metric 6917120
  Tag 40, type external
  Redistributing via eigrp 100, ospf 1
  Last update from 10.1.23.3 on Serial0/1, 00:29:07 ago
  Routing Descriptor Blocks:
  * 10.1.23.3, from 10.1.23.3, 00:29:07 ago, via Serial0/1
      Route metric is 6917120, traffic share count is 1
      Total delay is 20200 microseconds, minimum bandwidth is 400 Kbit
      Reliability 255/255, minimum MTU 1500 bytes
      Loading 1/255, Hops 1
      Route tag 40

Router 3
R3#show running-config

hostname R3
!
interface Serial0/0
 ip address 10.1.13.3 255.255.255.0
 clock rate 2000000
!
interface Serial0/1
 ip address 10.1.23.3 255.255.255.0
 clock rate 2000000
!
router eigrp 100
 redistribute ospf 1 route-map OSPF-TO-EIGRP
 network 10.1.23.0 0.0.0.255
 no auto-summary
!
router ospf 1
 router-id 3.3.3.3
 log-adjacency-changes
 redistribute eigrp 100 subnets route-map EIGRP-TO-OSPF
 network 10.1.13.3 0.0.0.0 area 0
!
access-list 1 permit 10.4.0.0 0.0.0.255
access-list 1 permit 10.4.1.0 0.0.0.255
access-list 2 permit 10.4.2.0 0.0.0.255
access-list 2 permit 10.4.3.0 0.0.0.255
access-list 3 permit 10.4.4.0 0.0.0.255
!
route-map EIGRP-TO-OSPF deny 5 (Deny Trafic With Tag)
 match tag 40
!
route-map EIGRP-TO-OSPF permit 10
 match ip address 1
 set metric 100
 set tag 10
!
route-map EIGRP-TO-OSPF permit 20
 match ip address 2
 set metric 200
 set tag 20
!
route-map EIGRP-TO-OSPF deny 30
 match ip address 3
!
route-map EIGRP-TO-OSPF permit 40  (Permit Any)
 set metric 300
 set tag 30
!
route-map OSPF-TO-EIGRP deny 5  (Deny Trafic With Tag)
 match tag 10 20 30
!
route-map OSPF-TO-EIGRP permit 10
 set metric 400 20 255 1 1500
 set tag 40
!
end

R3#show ip interface brief | in up
Serial0/0                  10.1.13.3       YES manual up                    up
Serial0/1                  10.1.23.3       YES manual up                    up

R3#show ip route
     10.0.0.0/24 is subnetted, 10 subnets
C       10.1.13.0 is directly connected, Serial0/0
O       10.1.12.0 [110/128] via 10.1.13.1, 01:32:12, Serial0/0
D       10.4.4.0 [90/2809856] via 10.1.23.2, 00:30:43, Serial0/1
O       10.1.0.0 [110/65] via 10.1.13.1, 01:32:12, Serial0/0
D       10.4.2.0 [90/2809856] via 10.1.23.2, 00:30:43, Serial0/1
D       10.4.3.0 [90/2809856] via 10.1.23.2, 00:30:43, Serial0/1
D       10.4.0.0 [90/2809856] via 10.1.23.2, 00:30:43, Serial0/1
D       10.4.1.0 [90/2809856] via 10.1.23.2, 00:30:45, Serial0/1
D       10.1.24.0 [90/2681856] via 10.1.23.2, 00:30:47, Serial0/1
C       10.1.23.0 is directly connected, Serial0/1

R3#show ip ospf neighbor
Neighbor ID     Pri   State           Dead Time   Address         Interface
1.1.1.1           0   FULL/  -        00:00:31    10.1.13.1       Serial0/0

R3#show ip eigrp neighbor
IP-EIGRP neighbors for process 100
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
0   10.1.23.2               Se0/1             11 00:31:10  488  2928  0  28

R3#show route-map
route-map EIGRP-TO-OSPF, deny, sequence 5
  Match clauses:
    tag 40
  Set clauses:
  Policy routing matches: 0 packets, 0 bytes
route-map EIGRP-TO-OSPF, permit, sequence 10
  Match clauses:
    ip address (access-lists): 1
  Set clauses:
    metric 100
    tag 10
  Policy routing matches: 0 packets, 0 bytes
route-map EIGRP-TO-OSPF, permit, sequence 20
  Match clauses:
    ip address (access-lists): 2
  Set clauses:
    metric 200
    tag 20
  Policy routing matches: 0 packets, 0 bytes
route-map EIGRP-TO-OSPF, deny, sequence 30
  Match clauses:
    ip address (access-lists): 3
  Set clauses:
  Policy routing matches: 0 packets, 0 bytes
route-map EIGRP-TO-OSPF, permit, sequence 40
  Match clauses:
  Set clauses:
    metric 300
    tag 30
  Policy routing matches: 0 packets, 0 bytes
route-map OSPF-TO-EIGRP, deny, sequence 5
  Match clauses:
    tag 10 20 30
  Set clauses:
  Policy routing matches: 0 packets, 0 bytes
route-map OSPF-TO-EIGRP, permit, sequence 10
  Match clauses:
  Set clauses:
    metric 400 20 255 1 1500
    tag 40
  Policy routing matches: 0 packets, 0 bytes


Router 4
R4#show running-config

hostname R4
!
interface Loopback0
 ip address 10.4.0.1 255.255.255.0
!
interface Loopback1
 ip address 10.4.1.1 255.255.255.0
!
interface Loopback2
 ip address 10.4.2.1 255.255.255.0
!
interface Loopback3
 ip address 10.4.3.1 255.255.255.0
!
interface Loopback4
 ip address 10.4.4.1 255.255.255.0
!
interface Serial0/0
 ip address 10.1.24.4 255.255.255.0
 clock rate 2000000
!
router eigrp 100
 network 10.0.0.0
 no auto-summary
!
end

R4#show ip interface brief | include up
Serial0/0                  10.1.24.4       YES manual up                    up
Loopback0                  10.4.0.1        YES manual up                    up
Loopback1                  10.4.1.1        YES manual up                    up
Loopback2                  10.4.2.1        YES manual up                    up
Loopback3                  10.4.3.1        YES manual up                    up
Loopback4                  10.4.4.1        YES manual up                    up

R4#show ip route
     10.0.0.0/24 is subnetted, 10 subnets
D EX    10.1.13.0 [170/7429120] via 10.1.24.2, 00:32:58, Serial0/0
D EX    10.1.12.0 [170/6917120] via 10.1.24.2, 00:32:58, Serial0/0
C       10.4.4.0 is directly connected, Loopback4
D EX    10.1.0.0 [170/7429120] via 10.1.24.2, 00:32:58, Serial0/0
C       10.4.2.0 is directly connected, Loopback2
C       10.4.3.0 is directly connected, Loopback3
C       10.4.0.0 is directly connected, Loopback0
C       10.4.1.0 is directly connected, Loopback1
C       10.1.24.0 is directly connected, Serial0/0
D       10.1.23.0 [90/2681856] via 10.1.24.2, 00:33:00, Serial0/0

R4#show ip eigrp neighbors
IP-EIGRP neighbors for process 100
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
0   10.1.24.2               Se0/0             11 00:33:32  358  2148  0  27

R4#traceroute 10.1.0.1
Tracing the route to 10.1.0.1

  1 10.1.24.2 152 msec 108 msec 112 msec  (R2)
  2 10.1.23.3 64 msec 116 msec 252 msec   (R3)
  3 10.1.13.1 108 msec *  176 msec        (R1)