22 May, 2013

Simple Redistribution Lab EIGRP-IN-OSPF GNS3

IPv4 Redistribution - Implementing Simple Redistribution GNS3



1. Configure EIGRP and OSPF for the network shown. Advertise all networks on all routers.Do not implement any summarization features for EIGRP or OSPF. Use Area 0 for the OSPF portion of the network and configure all Loopback interfaces on R3 as a point-to-point OSPF network.

2. Enable full redistribution between OSPF and EIGRP, implementing any necessary seed metrics to ensure all routers are able to see all routes. OSPF external routes should not increment their metric as they propagate the network.

3. Implement distribute-list filtering in such a way that the OSPF domain only sees odd numbered loopback networks coming from R1. Any even numbered subnet (including physical networks) should be hidden from OSPF.

4. Implement route-map filtering in such a way that the EIGRP domain does not see routes with a more specific subnet mask than /24.

To See Configuration Click Read More.


Router 1 
R1#show running-config
hostname R1
!
interface Loopback0
 ip address 10.1.0.1 255.255.255.0
!
interface Loopback1
 ip address 10.1.1.1 255.255.255.0
!
interface Loopback2
 ip address 10.1.2.1 255.255.255.0
!
interface Loopback3
 ip address 10.1.3.1 255.255.255.0
!
interface Loopback4
 ip address 10.1.4.1 255.255.255.0
!
interface Loopback5
 ip address 10.1.5.1 255.255.255.0
!
interface Loopback6
 ip address 10.1.6.1 255.255.255.0
!
interface Serial0/0
 ip address 10.1.12.1 255.255.255.0
 clock rate 2000000
!
router eigrp 100
 network 10.0.0.0
 no auto-summary
!
end

R1#show ip interface brief | include up
Serial0/0                  10.1.12.1       YES manual up                    up
Loopback0                  10.1.0.1        YES manual up                    up
Loopback1                  10.1.1.1        YES manual up                    up
Loopback2                  10.1.2.1        YES manual up                    up
Loopback3                  10.1.3.1        YES manual up                    up
Loopback4                  10.1.4.1        YES manual up                    up
Loopback5                  10.1.5.1        YES manual up                    up
Loopback6                  10.1.6.1        YES manual up                    up

R1#show ip route
     10.0.0.0/24 is subnetted, 13 subnets
D EX    10.1.10.0 [170/26137600] via 10.1.12.2, 00:33:01, Serial0/0
D EX    10.1.9.0 [170/26137600] via 10.1.12.2, 00:33:01, Serial0/0
D EX    10.1.8.0 [170/26137600] via 10.1.12.2, 00:33:01, Serial0/0
C       10.1.12.0 is directly connected, Serial0/0
C       10.1.3.0 is directly connected, Loopback3
C       10.1.2.0 is directly connected, Loopback2
C       10.1.1.0 is directly connected, Loopback1
C       10.1.0.0 is directly connected, Loopback0
D EX    10.1.7.0 [170/26137600] via 10.1.12.2, 00:33:03, Serial0/0
C       10.1.6.0 is directly connected, Loopback6
C       10.1.5.0 is directly connected, Loopback5
C       10.1.4.0 is directly connected, Loopback4
D EX    10.1.23.0 [170/26137600] via 10.1.12.2, 00:33:04, Serial0/0

R1#show ip eigrp neighbors
IP-EIGRP neighbors for process 100
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
0   10.1.12.2               Se0/0             12 01:03:02  166   996  0  11

Router 2
R2#show running-config
hostname R2
!
interface Serial0/0
 ip address 10.1.12.2 255.255.255.0
 clock rate 2000000
!
interface Serial0/1
 ip address 10.1.23.2 255.255.255.0
 clock rate 2000000
!
router eigrp 100
 redistribute ospf 1 metric 100 100 100 100 1500 route-map FILTER-OSPF-IN-EIGRP
 network 10.1.12.0 0.0.0.255
 no auto-summary
!
router ospf 1
 router-id 2.2.2.2
 log-adjacency-changes
 redistribute eigrp 100 subnets
 network 10.1.23.0 0.0.0.255 area 0
 distribute-list 1 out
!
ip prefix-list georgia seq 5 permit 10.0.0.0/8 le 24
access-list 1 permit 10.1.1.0 0.0.0.255
access-list 1 permit 10.1.3.0 0.0.0.255
access-list 1 permit 10.1.5.0 0.0.0.255
!
route-map FILTER-OSPF-IN-EIGRP permit 10
 match ip address prefix-list georgia
!
end

R2#show ip interface brief | exclude unassigned
Interface                  IP-Address      OK? Method Status                Protocol
Serial0/0                  10.1.12.2       YES manual up                    up
Serial0/1                  10.1.23.2       YES manual up                    up

R2#show ip route
     10.0.0.0/8 is variably subnetted, 16 subnets, 2 masks
O       10.1.11.0/30 [110/65] via 10.1.23.3, 00:59:52, Serial0/1
O       10.1.10.0/24 [110/65] via 10.1.23.3, 00:59:52, Serial0/1
O       10.1.9.0/24 [110/65] via 10.1.23.3, 00:59:52, Serial0/1
O       10.1.8.0/24 [110/65] via 10.1.23.3, 00:59:52, Serial0/1
O       10.1.11.4/30 [110/65] via 10.1.23.3, 00:59:52, Serial0/1
C       10.1.12.0/24 is directly connected, Serial0/0
O       10.1.11.8/30 [110/65] via 10.1.23.3, 00:59:52, Serial0/1
D       10.1.3.0/24 [90/2297856] via 10.1.12.1, 01:07:42, Serial0/0
D       10.1.2.0/24 [90/2297856] via 10.1.12.1, 01:07:42, Serial0/0
D       10.1.1.0/24 [90/2297856] via 10.1.12.1, 01:07:42, Serial0/0
D       10.1.0.0/24 [90/2297856] via 10.1.12.1, 01:07:42, Serial0/0
O       10.1.7.0/24 [110/65] via 10.1.23.3, 00:59:53, Serial0/1
D       10.1.6.0/24 [90/2297856] via 10.1.12.1, 01:07:42, Serial0/0
D       10.1.5.0/24 [90/2297856] via 10.1.12.1, 01:07:42, Serial0/0
D       10.1.4.0/24 [90/2297856] via 10.1.12.1, 01:07:42, Serial0/0
C       10.1.23.0/24 is directly connected, Serial0/1

R2#show access-lists
Standard IP access list 1
    10 permit 10.1.1.0, wildcard bits 0.0.0.255 (1 match)
    20 permit 10.1.3.0, wildcard bits 0.0.0.255 (1 match)
    30 permit 10.1.5.0, wildcard bits 0.0.0.255 (1 match)

R2#show ip prefix-list
ip prefix-list georgia: 1 entries
   seq 5 permit 10.0.0.0/8 le 24

R2#show route-map
route-map FILTER-OSPF-IN-EIGRP, permit, sequence 10
  Match clauses:
    ip address prefix-lists: georgia
  Set clauses:
  Policy routing matches: 0 packets, 0 bytes

Router 3
R3#show running-config
hostname R3
!
interface Loopback7
 ip address 10.1.7.1 255.255.255.0
 ip ospf network point-to-point
!
interface Loopback8
 ip address 10.1.8.1 255.255.255.0
 ip ospf network point-to-point
!
interface Loopback9
 ip address 10.1.9.1 255.255.255.0
 ip ospf network point-to-point
!
interface Loopback10
 ip address 10.1.10.1 255.255.255.0
 ip ospf network point-to-point
!
interface Loopback11
 ip address 10.1.11.1 255.255.255.252
 ip ospf network point-to-point
!
interface Loopback12
 ip address 10.1.11.5 255.255.255.252
 ip ospf network point-to-point
!
interface Loopback13
 ip address 10.1.11.9 255.255.255.252
 ip ospf network point-to-point
!
interface Serial0/1
 ip address 10.1.23.3 255.255.255.0
 clock rate 2000000
!
router ospf 1
 router-id 3.3.3.3
 log-adjacency-changes
 network 10.0.0.0 0.255.255.255 area 0
!
end

R3#show ip interface brief | include up
Serial0/1                  10.1.23.3       YES manual up                    up
Loopback7                  10.1.7.1        YES manual up                    up
Loopback8                  10.1.8.1        YES manual up                    up
Loopback9                  10.1.9.1        YES manual up                    up
Loopback10                 10.1.10.1       YES manual up                    up
Loopback11                 10.1.11.1       YES manual up                    up
Loopback12                 10.1.11.5       YES manual up                    up
Loopback13                 10.1.11.9       YES manual up                    up

R3#show ip route
C       10.1.11.0/30 is directly connected, Loopback11
C       10.1.10.0/24 is directly connected, Loopback10
C       10.1.9.0/24 is directly connected, Loopback9
C       10.1.8.0/24 is directly connected, Loopback8
C       10.1.11.4/30 is directly connected, Loopback12
C       10.1.11.8/30 is directly connected, Loopback13
O E2    10.1.3.0/24 [110/20] via 10.1.23.2, 00:31:10, Serial0/1
O E2    10.1.1.0/24 [110/20] via 10.1.23.2, 00:31:10, Serial0/1
C       10.1.7.0/24 is directly connected, Loopback7
O E2    10.1.5.0/24 [110/20] via 10.1.23.2, 00:31:12, Serial0/1
C       10.1.23.0/24 is directly connected, Serial0/1

R3#show ip ospf neighbor
Neighbor ID     Pri   State           Dead Time   Address         Interface
2.2.2.2           0   FULL/  -        00:00:31    10.1.23.2       Serial0/1