Objective:
1) Configure Virtual Link between R2 and R3 (in Area 1)
To See Configuration Click Read More.
Router 1
R1#show running-config
hostname R1
!
interface Loopback0
ip address 10.1.1.1 255.255.255.255
!
interface Serial1/0
ip address 10.1.2.1 255.255.255.252
clock rate 2016000
!
router ospf 1
router-id 1.1.1.1
network 10.0.0.0 0.255.255.255 area 0
!
end
R1#show ip interface brief
Interface IP-Address OK? Method Status Protocol
Serial1/0 10.1.2.1 YES manual up up
Loopback0 10.1.1.1 YES manual up up
R1#show ip route ospf
O IA 172.16.2.0/30 [110/128] via 10.1.2.2, 00:22:33, Serial1/0
O IA 172.16.2.0/24 [110/192] via 10.1.2.2, 00:13:02, Serial1/0
10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
O 10.2.2.2/32 [110/65] via 10.1.2.2, 00:25:21, Serial1/0
O IA 192.168.1.1 [110/129] via 10.1.2.2, 00:13:02, Serial1/0
Router 2
R2#show running-config
!
hostname R2
!
interface Loopback0
ip address 10.2.2.2 255.255.255.255
!
interface Serial1/0
ip address 10.1.2.2 255.255.255.252
clock rate 2016000
!
interface Serial1/1
ip address 172.16.2.1 255.255.255.252
clock rate 2016000
!
router ospf 1
router-id 2.2.2.2
area 1 virtual-link 3.3.3.3
network 10.0.0.0 0.255.255.255 area 0
network 172.16.2.0 0.0.0.255 area 1
!
end
R2#show ip interface brief | exclude unassigned
Interface IP-Address OK? Method Status Protocol
Serial1/0 10.1.2.2 YES manual up up
Serial1/1 172.16.2.1 YES manual up up
Loopback0 10.2.2.2 YES manual up up
R2#show ip route ospf
O 172.16.2.0/24 [110/128] via 172.16.2.2, 00:21:31, Serial1/1
10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
O 10.1.1.1/32 [110/65] via 10.1.2.1, 00:26:27, Serial1/0
192.168.1.0/32 is subnetted, 1 subnets
O IA 192.168.1.1 [110/65] via 172.16.2.2, 00:15:55, Serial1/1
Router 3
R3#show running-config
hostname R3
!
interface Loopback0
ip address 192.168.1.1 255.255.255.0
!
interface Serial1/0
ip address 172.16.2.2 255.255.255.0
clock rate 2016000
!
router ospf 1
router-id 3.3.3.3
area 1 virtual-link 2.2.2.2
network 172.16.2.0 0.0.0.255 area 1
network 192.168.1.0 0.0.0.255 area 2
!
end
R3#show ip interface brief | include up
Serial1/0 172.16.2.2 YES manual up up
Loopback0 192.168.1.1 YES manual up up
R3#show ip route ospf
O 172.16.2.0/30 [110/128] via 172.16.2.1, 00:21:56, Serial1/0
10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
O 10.2.2.2/32 [110/65] via 172.16.2.1, 00:21:41, Serial1/0
O 10.1.2.0/30 [110/128] via 172.16.2.1, 00:21:41, Serial1/0
O 10.1.1.1/32 [110/129] via 172.16.2.1, 00:21:41, Serial1/0